Opened 9 years ago

Closed 9 years ago

#5568 closed defect (fixed)

KQ5 French:only partial English text

Reported by: SF/aroenai Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 5

Description

When attempting to start a new game, the game crashes with

ERROR: Failed to locate base object for object at 002D:0AA6!

Also when the English language option is selected in settings, not all the text is switched ("Have you previously played King's Quest V?" shows up correctly, but all the text in the introduction is in French). This is the French floppy version included with the 1994 King's Quest collection CD set.

Ticket imported from: #3150767. Ticket imported from: bugs/5568.

Change History (8)

comment:1 by lordhoto, 9 years ago

To process your bug report appropriately, please be so kind and provide the following information, if you have not done so yet:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by lordhoto, 9 years ago

Summary: KQ5 French crash on startup, only partial English textKQ5 French: Crash on startup, only partial English text

comment:3 by SF/aroenai, 9 years ago

Whoops, I can't believe I forgot that. Anyway:

SVN r55102

Actual gameplay will not start, either watch the intro or click yes (the button on the right) at the prompt. As for the problem with english text not showing up, select English in the edit game options.

French

Floppy (from the 1994 King's Quest Collection)

Win32

Not possible, game does not progress far enough to save.

comment:4 by SF/aroenai, 9 years ago

Summary: KQ5 French: Crash on startup, only partial English textKQ5 French crash on startup, only partial English text

comment:5 by bluegr, 9 years ago

Partially fixed in r55122, a regression from r54510, duplicate of bug #3035396.

The crash has been fixed. I'm leaving this open, with a modified description, because of the other problem reported (when selecting English, not all of the text is in English)

comment:6 by bluegr, 9 years ago

Summary: KQ5 French crash on startup, only partial English textKQ5 French:only partial English text

comment:7 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:8 by bluegr, 9 years ago

I've just fixed a related bug in r55561 - multilingual games would reset to non-English when restarting.

The problem with the text in the intro is that the French texts have no English counterparts (e.g. TEX files 100, 101, 102, 103, 104, 105, 107, 108, 109). So this is not a bug, but a missing feature from the game itself. Thus I'm closing this as resolved.

Note: See TracTickets for help on using tickets.