Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5561 closed defect (fixed)

ACTIVITY: Circus Stormin' crash

Reported by: SF/jediscumm Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Putt-Putt & Fatty Bear's Activity Pack

Description

Hi everyone,

Circus Stormin', a game in Putt-Putt and Fatty Bear's Activity Pack, always crashes after level 52 with the following error message in the debugger:
ERROR: (3:202:0xF69): redimArray: array 25 redim mismatch!

I'd really appreciate a fix for this.
jediscumm

Ticket imported from: #3143039. Ticket imported from: bugs/5561.

Change History (5)

comment:1 by SF/jediscumm, 9 years ago

# ScummVM version 1.3.0 and v1.3.0svn54975
Windows CD-Rom version (1994)

comment:2 by SF/jediscumm, 9 years ago

Owner: set to Kirben

comment:3 by Kirben, 9 years ago

Resolution: fixed
Status: newclosed
Summary: Putt-Putt Activity Pack- Circus Stormin' crashACTIVITY: Circus Stormin' crash

comment:4 by Kirben, 9 years ago

The problem was caused by a workaround in ScummEngine_v6::getArray() been incorrectly triggered.

Fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

comment:5 by Kirben, 9 years ago

Component: Engine: SCUMM
Game: Putt-Putt & Fatty Bear's Activity Pack
Note: See TracTickets for help on using tickets.