Opened 9 years ago

Closed 9 years ago

Last modified 10 months ago

#5556 closed defect (duplicate)

GOB Engine: IOS version mouse unusable

Reported by: SF/illuminerdi Owned by:
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Lost in Time

Description

In ScummVM 1.2.1 for IOS the mouse does not function in Lost In Time. The cursor follows the users touch but does not left or right click correctly in either normal or touchpad mode.

Tested on an iPad running iOS 4.2.1

Furthermore, the ScummVM menu could not be brought up using the standard gesture, forcing the user to kill scummvm to exit the game.

Ticket imported from: #3140372. Ticket imported from: bugs/5556.

Change History (6)

comment:1 Changed 9 years ago by SF/illuminerdi

After doing further research i have come to believe that this bug affects all games using the GOB engine, as i tested Gobliins 2 cd version and it had the same bugs. I have not yet had time to test other games but I'm assuming that since all the coktel vision games use this scummvm module they will all suffer this bug.

comment:2 Changed 9 years ago by SF/illuminerdi

Component: Engine: Gob--Unset--
Game: Lost in Time
Summary: Lost In Time CD: IOS version mouse unusableGOB Engine: IOS version mouse unusable

comment:3 Changed 9 years ago by vinterstum

Dupe of 3018512

comment:4 Changed 9 years ago by vinterstum

Resolution: duplicate
Status: newclosed

comment:5 Changed 9 years ago by vinterstum

(https://sourceforge.net/tracker/?func=detail&aid=3018512&group_id=37116&atid=418820)

comment:6 Changed 10 months ago by digitall

Component: --Unset--Engine: Gob
Game: Lost in Time
Note: See TracTickets for help on using tickets.