Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5550 closed defect (fixed)

NIPPON: no speech Mr.Y into the bath room

Reported by: SF/windlepoons Owned by: bluegr
Priority: normal Component: Engine: Parallaction
Keywords: script Cc:
Game: Nippon Safes

Description

In Sento baths, hit the gong and speech with Mr. Y.
Dino is out of the bath room (previous the gong door) and i can't speech with sumo man in Kinza.

Correctly, Mr. Y speech with Dino into the bath room.

Nippon Safes Inc. (Multi-lingual/DOS)
ScummVM 1.2.1 and 1.3.0svn (Dec 12 2010 12:49:08)

Ticket imported from: #3135868. Ticket imported from: bugs/5550.

Attachments (3)

nippon.010 (350 bytes) - added by SF/windlepoons 9 years ago.
nippon.020 (324 bytes) - added by SF/windlepoons 9 years ago.
before enter the arena
nippon.021 (328 bytes) - added by SF/windlepoons 9 years ago.
after enter the arena

Download all attachments as: .zip

Change History (18)

Changed 9 years ago by SF/windlepoons

Attachment: nippon.010 added

comment:1 Changed 9 years ago by jvprat

Owner: set to peres
Summary: Nippon: no speech Mr.Y into the bath roomNIPPON: no speech Mr.Y into the bath room

Changed 9 years ago by SF/windlepoons

Attachment: nippon.020 added

before enter the arena

Changed 9 years ago by SF/windlepoons

Attachment: nippon.021 added

after enter the arena

comment:2 Changed 9 years ago by SF/windlepoons

I upload two savegame with Dino:
before and after enter first time the arena.

comment:3 Changed 8 years ago by SF/andrea2054

I have the same issue with version 1.3.1.
I noticed that the punch remains in the inventory after hitting the gong (I think it should disappear, maybe it triggers the speech with sumo man)

comment:4 Changed 8 years ago by SF/andrea2054

This is a blocking issue; the Dino path is broken.

comment:5 Changed 8 years ago by SF/windlepoons

Dino and Doug (bug 2880939) path are broken.

comment:6 Changed 8 years ago by SF/windlepoons

Priority: normalblocker

comment:7 Changed 8 years ago by wjp

What is the relation of this punch/gong issue to this "Mr. Y speech" bug report?

comment:8 Changed 8 years ago by wjp

Priority: blockernormal

comment:9 Changed 8 years ago by wjp

Ah, never mind. I can't read, it seems.

comment:10 Changed 8 years ago by digitall

The issue is still replicated from the attached savegames with the latest Git
master:
ScummVM 1.4.0git1898-g6ab4a0c (Aug 31 2011 21:57:38)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib
FluidSynth Theora AAC

Will need to check that this can be replicated from a clean game start.

After you speak to Mr Y. before the rest of the dialogue continues, the location changes to the room with the Gong, I suspect this difference may be causing this issue.

I initially thought that this was the same problem as bug #2880939 "NIPPON: No Elder", but the patch from that bug preventing Scripted Walks going through Door hitzones did not fix this issue.

comment:11 Changed 8 years ago by SF/andrea2054

Issue tested and confirmed not solved with version 1.4.0git1931-gcb410d5.
As soon as possible I test if this can be replicated from a clean game start (it is difficult because of bug #3322951).

comment:12 Changed 8 years ago by digitall

Have bisected and found that the room change issue was introduced between 0.12.0 and 0.13.0 by:
774773b7cd02e3c6932095af4905a25eb1862392
peres 2008-12-17 11:15:47
Reduced code duplication when manipulating Animations, and cleanup.
svn-id: r35408

However, I'm not sure that this is the entire issue as I can seem to speak to Mr Y still....

comment:13 Changed 8 years ago by bluegr

Fixed in commit 2883ebc

comment:14 Changed 8 years ago by bluegr

Owner: changed from peres to bluegr
Resolution: fixed
Status: newclosed

comment:15 Changed 8 years ago by bluegr

Note: same cause as bug #2880939

Note: See TracTickets for help on using tickets.