Opened 9 years ago

Closed 8 years ago

#5541 closed defect (worksforme)

AGI: SQ2: Shuttle gets stuck

Reported by: SF/tprec Owned by:
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: Space Quest 2

Description

Shuttle gets stuck before entering Vohauls asteroid.

Tested with nightly build ScummVM 1.3.0svn54694 on Windows Vista 64bit and ScummVM 1.2.0 on Gentoo Linux with vanilla kernel 2.6.34.5 and gcc x86_64-pc-linux-gnu-4.4.4. The savegame was produced with ScummVM 1.2.0 on WindowsXP iirc.

To reproduce the bug load the attached savegame sq2.014 and wait. While the shuttle is approaching the asteroid the
animation suddenly stops and hangs infinitely.

The game is advertised as Space Quest II: Vohaul's Revenge (2.0A 1987-11-06 5.25"/DOS/English).

Ticket imported from: #3124905. Ticket imported from: bugs/5541.

Attachments (3)

sq2.014 (5.8 KB) - added by SF/tprec 9 years ago.
Savegame demonstrating bug.
sq2-nobug.txt (1.2 KB) - added by digitall 8 years ago.
MD5sums of SQ2 Version not showing bug
sq2-bug.txt (833 bytes) - added by SF/tprec 8 years ago.
MD5sums of SQ2 Version showing bug

Download all attachments as: .zip

Change History (19)

Changed 9 years ago by SF/tprec

Attachment: sq2.014 added

Savegame demonstrating bug.

comment:1 Changed 9 years ago by jvprat

Summary: Shuttle gets stuckSQ2: Shuttle gets stuck

comment:2 Changed 9 years ago by bluegr

Summary: SQ2: Shuttle gets stuckSQ2 (AGI): Shuttle gets stuck

comment:3 Changed 9 years ago by bluegr

Summary: SQ2 (AGI): Shuttle gets stuckSQ2: Shuttle gets stuck

comment:4 Changed 9 years ago by digitall

Can _not_ replicate with ScummVM 1.3.0svn54722 (Dec 2 2010 00:01:48) and
Space Quest II: Vohaul's Revenge (2.0F 1989-01-05 3.5"/DOS/English) i.e. from
Space Quest Collection.

No changes between r54694 and r54722 to AGI, so this is probably due to a fix in
the newer script in game version 2.0F compared to V2.0A

Will need developer with V2.0A version to look at this.

comment:5 Changed 9 years ago by (none)

I tried your savegame and it's working. No freezes, Roger safely lands inside the asteroid and exited the shuttle. Had to make him fall from the platform though... :lol:

I don't know the version of my copy, but I got this game around late 80's. It could be version 1.00.

comment:6 Changed 9 years ago by (none)

ah... got it. It's on the intro. Silly me... :p

My version is 2.0F.

comment:7 Changed 8 years ago by digitall

tprec: Sorry about the long delay, but haven't known quite how to progress. I suggest that the best idea is for you to attach a list of the datafiles for your version of SQ2 with MD5sums. The output of a tool such as http://md5summer.org/ pointed at your SQ2 datafiles would be optimal. This will allow us to specifically identify the version you are using.

I will attach an output for my SQ2 version for reference.

Changed 8 years ago by digitall

Attachment: sq2-nobug.txt added

MD5sums of SQ2 Version not showing bug

comment:8 Changed 8 years ago by bluegr

Summary: SQ2: Shuttle gets stuckAGI: SQ2: Shuttle gets stuck

Changed 8 years ago by SF/tprec

Attachment: sq2-bug.txt added

MD5sums of SQ2 Version showing bug

comment:9 Changed 8 years ago by bluegr

I have tried the savegame with both versions (2.0A and 2.0F) and I can't reproduce this with either version. It seems to be an issue that has already been fixed, or your game data files look to be corrupted. Try it with a daily build, it should be fixed

comment:10 Changed 8 years ago by digitall

Resolution: worksforme
Status: newpending

comment:11 Changed 8 years ago by digitall

Since this is likely to be fixed or corrupt datafiles, I will set this pending.

If the bug submitter does not comment within 14 days, it will be closed automatically.

comment:12 Changed 8 years ago by SF/tprec

thebluegr: can you please attach md5sums of your 2.0a datafiles? I assume tdhs' sq2-nobug.txt is for version 2.0f, right?

comment:13 Changed 8 years ago by SF/tprec

Status: pendingnew

comment:14 Changed 8 years ago by bluegr

Version 2.0A is the same as the one posted already, HOWEVER you don't have vol.3, and my version does... try recopying this file from your original media

Version 2.0F is the same as the one posted already

comment:15 Changed 8 years ago by SF/tprec

Status: newclosed

comment:16 Changed 8 years ago by SF/tprec

Yes you are right vol.3 was missing. Sorry for making a big thing of it. It was not clear to me that the game just stops without any notice in such a case. Thanks for clearing that up.

Note: See TracTickets for help on using tickets.