Opened 17 years ago

Closed 17 years ago

#554 closed defect (fixed)

LOOM: New graphic glitch during escape

Reported by: SF/dfabulich Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

In Mandible's dungeon, cast Open (e c e d) on the cage
door. As you're jumping out of the cage, you'll be
incorrectly obscured.

Using ScummVM 0.2.7 CVS
Built on Nov 8 2002 20:34:06

Ticket imported from: #635491. Ticket imported from: bugs/554.

Attachments (2)

loomcd.s05 (41.1 KB) - added by SF/dfabulich 17 years ago.
Saved game right before escape
escape.png (81.0 KB) - added by SF/dfabulich 17 years ago.
Screenshot of glitch

Download all attachments as: .zip

Change History (8)

Changed 17 years ago by SF/dfabulich

Attachment: loomcd.s05 added

Saved game right before escape

comment:1 Changed 17 years ago by SF/dfabulich

I've attached a saved game and a screen shot.

Changed 17 years ago by SF/dfabulich

Attachment: escape.png added

Screenshot of glitch

comment:2 Changed 17 years ago by SF/andrej4000

Seems to be a layer problem or so...

comment:3 Changed 17 years ago by eriktorbjorn

I believe this should be fixed now. Could anyone please
verify that?

comment:4 Changed 17 years ago by SF/dfabulich

Looks good to me. (I didn't do a full regression; I just
verified that the bug was fixed.) Works correctly as of:

ScummVM 0.2.81 CVS
Built on Nov 13 2002 17:03:53

comment:5 Changed 17 years ago by eriktorbjorn

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:6 Changed 17 years ago by eriktorbjorn

It should be ok then. The fix I submitted for this bug
simply extended the hack to fix layering problems in another
room in Loom to also cover this room.

I do wish I knew how to fix it in a non-hacky way, though...

Note: See TracTickets for help on using tickets.