Opened 9 years ago

Closed 9 years ago

#5539 closed defect (fixed)

TOON: loss of inventory items in Bricabrac's machine room

Reported by: SF/hmilchuser Owned by: sylvaintv
Priority: normal Component: Engine: Toon
Keywords: Cc:
Game: Toonstruck

Description

If you leave the machine-room behind Bricabrac-room while Bricabrac puts all your items back to the machine you can play on but all your items are lost.

Language: German
Version: Win32 ScummVM Daily Snapshot (build from Subversion, 4506K Win32 exe file, last update: December 1, 2010, 5:17 am)

Regards Thomas

Ticket imported from: #3124518. Ticket imported from: bugs/5539.

Attachments (3)

toon.021 (24.7 KB ) - added by digitall 9 years ago.
Savegame outside Machine Room with all necessary items
after_leave.png (122.0 KB ) - added by SF/hmilchuser 9 years ago.
screenshot - room after leaving the machine
toon-de.022 (24.5 KB ) - added by SF/hmilchuser 9 years ago.
Savegame outside Machine Room after leaving - Items lost

Download all attachments as: .zip

Change History (11)

comment:1 by bluegr, 9 years ago

Summary: lose of items of the inventary in Bricabrac-machine-roomTOON: loss of inventory items in Bricabrac's machine room

comment:2 by fingolfin, 9 years ago

Owner: set to sylvaintv

by digitall, 9 years ago

Attachment: toon.021 added

Savegame outside Machine Room with all necessary items

comment:3 by digitall, 9 years ago

Can't replicate this loss of inventory with attached savegame and current SVN HEAD i.e. r55402.

by SF/hmilchuser, 9 years ago

Attachment: after_leave.png added

screenshot - room after leaving the machine

by SF/hmilchuser, 9 years ago

Attachment: toon-de.022 added

Savegame outside Machine Room after leaving - Items lost

comment:4 by SF/hmilchuser, 9 years ago

OK! in the current version of scummVM (1.3.0.svn55526) it is quite hard to trap into the bug.
1.) put some items in the machine
2.) leave the room
3.) enter the room again and click (right mouse key) on the door (in about the first 10ms) - then sometimes you:
- lose of some Items
- Draw is not visible (see screenshot)
- the professor did not move any more (hees frees)
- the exit-door is closed

=>see Savegame "toon-de.022"!

(maybee it is crucial to enter the room while the professor does something: talk/animation (see screenshot - after exit again!) )

sorry for this sporadically bug :-(

Regards Thomas

comment:5 by SF/hmilchuser, 9 years ago

additional to my post from "Date: 2011-01-25 20:20:38 GMT":
-> I noticed the bug when I decided to enter the "Machine Room" and right before Draw entered this room I change my mind and want to leave the "Professors Room" to the castle. The Problem is that the both exit-door-area of "Machine Room" and "Professors Room" are almost the same. So you need some "luck" to trigger the bug but it is not impossible!

Regards Thomas

comment:6 by digitall, 9 years ago

Ah, managed to replicate. The issue may be related to Flux still being partly visble on the left of the machine room, with him triggering a return to the Professor's Room.

This may be an original engine script issue.

comment:7 by sylvaintv, 9 years ago

Resolution: fixed
Status: newclosed

comment:8 by sylvaintv, 9 years ago

Fixed in rev 55641

Note: See TracTickets for help on using tickets.