Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#553 closed defect (worksforme)

MI1 (Mac): Crashes when entering bar

Reported by: SF/impcat Owned by: SF/ender
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

The Floppy Macintosh version of Monkey Island 1 will crash when you select to Open the Door to the SCUMM bar. This happens every time you try to do it.

This bug is reproduced with:
ScummVM 0.2.7 CVS
Built on Nov 6 2002 01:19:31

kasumi[impact]:~> gcc --version
2.95.4
kasumi[impact]:~> uname -srm
FreeBSD 4.7-STABLE i386

Ticket imported from: #635476. Ticket imported from: bugs/553.

Change History (10)

comment:1 by fingolfin, 17 years ago

Does it crash with a particular error message?

If not, could you provide a stack trace? to do so, first start gdb with
scummvm:

gdb scummvm

Then in gdb, enter this command:
run OPTIONS
where OPTIONS is any options you normally would pass to scummvm.
Then once the game crashes, you can type this command
bt
which will generate a backtrace. Copy that to a file and attach it to teh
bug report. Thanks!

comment:2 by SF/impcat, 17 years ago

This is what gdb gives me, not very helpful i guess...

Loading room 33

Program received signal SIGSEGV, Segmentation fault.
0x28238b08 in memcpy () from /usr/lib/libc_r.so.4
(gdb) bt
#0 0x28238b08 in memcpy () from /usr/lib/libc_r.so.4
#1 0xa5110000 in ?? ()
Error accessing memory address 0xd145: Bad address.

comment:3 by SF/impcat, 17 years ago

Priority: normalhigh

comment:4 by fingolfin, 17 years ago

When you "floppy version", do you mean it is monkeyvga? For
the records, my version of monkeyvga/mac/german doesn't have
this problem with current CVS.
Are you using a save game or are you starting a game from
scratch to reproduce this bug?

comment:5 by SF/impcat, 17 years ago

It is not monkeyvga, I use game description "monkey1" to start it. It has been restored from hard disk backup.
The files are called monkey1.000 and monkey1.001, is this some kind of strange version?

comment:6 by fingolfin, 17 years ago

It is some kind of strange version, yeah, but that is no
excuse for it to crash of course :-)

Can't reproduce any crash with my "normal" version ('monkey'
with monkey.000 and monkey.001).

But we have been seeing some strange errors with memory
corruption recently, maybe you are simply hitting this
problem...

comment:7 by fingolfin, 17 years ago

Any idea Ender? If not I suggest closing this as WORKSFORME.

comment:8 by fingolfin, 17 years ago

Owner: set to SF/ender

comment:9 by SF/ender, 17 years ago

Sounds simply that the files are corrupt.

Closing - sorry, if the crash doesn't happen for any of us, it's kind
of hard to find the cause and fix it :)

comment:10 by SF/ender, 17 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.