Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5513 closed defect (fixed)

PQ1SCI: Lock-up on loading save game on Caanoo

Reported by: SF/surdules Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 1

Description

ScummVM version: 1.2.0, GP2X Caanoo. I cannot use the latest nightly build because there is no official nightly build for the Caanoo.

Bug details: ScummVM locks-up when loading certain save games in Police Quest 1 VGA (the SCI version). I have to turn off the GP2X and turn it back on. The same save-game works on the PC version of ScummVM. Not all save games cause lock-up on the Caanoo for this game, only some. To reproduce:

- Copy the attached savegame to the scummvm/saves folder on the Caanoo
- Launch ScummVM on the Caanoo
- Select "Police Quest 1" in the list of games, click Load, load the savegame
- ScummVM will lock-up hard and the only way to get out of it is to reboot the Caanoo from the power button
- If you copy the same savegame file on the PC, you will be able to load it
- The savegame is from when Sonny Bonds intercepts the silver Mercedes for the first time, about 25% of the way into the game
- Other savegames around that same time lock-up, although some savegames work, the behavior seems to be pretty random

Language of game: English

Version of game: The official Police Quest 1 VGA (SCI). This game is listed as 95% compatible on the games compatibility page.

Platform and compiler: GP2X Caanoo

Ticket imported from: #3108886. Ticket imported from: bugs/5513.

Attachments (1)

pq1sci.011 (38.5 KB ) - added by SF/surdules 9 years ago.
Save game file that causes lock-up on the Caanoo with Police Quest 1 VGA. The same file works fine in the PC version of ScummVM.

Download all attachments as: .zip

Change History (13)

by SF/surdules, 9 years ago

Attachment: pq1sci.011 added

Save game file that causes lock-up on the Caanoo with Police Quest 1 VGA. The same file works fine in the PC version of ScummVM.

comment:1 by digitall, 9 years ago

surdules :
Please could you test with the latest v1.2.0 branch nightly build for Caanoo :
http://buildbot.scummvm.org/snapshots/1.2.0/caanoo-1.2.0-latest.tar.bz2
If this does not resolve the bug, please test with latest nightly trunk build for Caanoo :
http://buildbot.scummvm.org/snapshots/trunk/caanoo-trunk-latest.tar.bz2

Also, when a "lockup" occurs, if you could try the exit key combinations and Return To Launcher
combinations to see if any work :
http://wiki.scummvm.org/index.php/Caanoo

comment:2 by digitall, 9 years ago

Owner: set to djwillis

comment:3 by bluegr, 9 years ago

Summary: Lock-up on loading save game on CaanooPQ1SCI: Lock-up on loading save game on Caanoo

comment:4 by SF/surdules, 9 years ago

1). I tried to reproduce the bug with the latest 1.2.0 branch build (caanoo-1.2.0-r54227). This build will not run on the Caanoo -- as soon as I launch it, it appears to crash, and I return back to the Home screen.

2). I then tried with the latest trunk build (caanoo-trunk-r54237). This build locks up on the savegame, just like the official build.

3). None of the exit key combinations work, on either the official build, or the trunk build above.

comment:5 by SF/surdules, 9 years ago

I also wanted to clarify that the lockup happens about half-way through the game. I can save/load just fine before that point.

comment:6 by bluegr, 9 years ago

I suspect this is related to the music code, for which a lot of changes have been made. Can you please test if this still occurs?

comment:7 by bluegr, 9 years ago

Resolution: fixed
Status: newpending

comment:8 by bluegr, 9 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:9 by bluegr, 9 years ago

Since there has been no feedback on this, I assume that it has been fixed already. I can't reproduce any issues/crashes/freezes on a PC platform.

Daily builds (including Caanoo builds) can be found at:
http://buildbot.scummvm.org/builds.html

comment:10 by bluegr, 9 years ago

Owner: changed from djwillis to bluegr

comment:11 by SF/sf-robot, 9 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:12 by SF/sf-robot, 9 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.