Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5494 closed defect (fixed)

Eco Quest 1 - Ending crashed

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: EcoQuest 1

Description

Language: English
Version: Floppy ver x.yyy & CD Talkie ver 1.1
ScummVM version: 1.2.0 (x64) and 1.3.0svn54035 (x64, Nov 2, 2010)

At the ending where the boy waves at the sea and later on the dolphin splashed, ending credit should have rolled. But instead it crashes directly without error message. Happens on both floppy and CD Talkie version.

Ticket imported from: #3101846. Ticket imported from: bugs/5494.

Attachments (2)

ecoquest-1.000 (35.3 KB ) - added by SF/*anonymous 9 years ago.
CD talkie version - at final battle. Just need to stick the needle to win and view ending to the end to see crash.
ecoquest.001 (40.9 KB ) - added by SF/*anonymous 9 years ago.
the floppy version - same position as with the cd talkie version

Download all attachments as: .zip

Change History (16)

by SF/*anonymous, 9 years ago

Attachment: ecoquest-1.000 added

CD talkie version - at final battle. Just need to stick the needle to win and view ending to the end to see crash.

by SF/*anonymous, 9 years ago

Attachment: ecoquest.001 added

the floppy version - same position as with the cd talkie version

comment:1 by m-kiewitz, 9 years ago

i tried with my own saves from my walkthrough and it worked flawlessly

comment:2 by (none), 9 years ago

I have tried it again and both version still crashed. I managed to get one though.

Prerequisite-Both: played the final battle and going through the ending sequence.

Floppy: right after the last dialog with Delphineus and loading the next screen, this occurs:
"ERROR: picture resource 680 not found!"

CD:
About 1 second after the credit rolled, the emulator freeze for a long time. Suddenly much later on, a restore-restart-quit menu pop-up. Credits cannot be seen. And after selecting one of the option, it freezes again and this time it's indefinitely. Here's the error:

*****
Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: scummvm-r54035.exe
Application Version: 1.3.0.0
Application Timestamp: 4ccfafe0
Hang Signature: 6519
Hang Type: 514
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 1033
Additional Hang Signature 1: 651954c23ae0f29eec64bf56a20ab40c
Additional Hang Signature 2: fac0
Additional Hang Signature 3: fac0302de2627539e5385f84739839ef
Additional Hang Signature 4: 6519
Additional Hang Signature 5: 651954c23ae0f29eec64bf56a20ab40c
Additional Hang Signature 6: fac0
Additional Hang Signature 7: fac0302de2627539e5385f84739839ef
*****

BTW, my floppy version came from the original floppy diskettes backup way back then. You might be using a newer version, because I remember bought it when it first came out at stores. My floppy version was x.yyy (it was on the About icon), date 12/23/1991

And here's my laptop specs where I played this, in case it might have something to do with this:
ASUS UL30VT. - Core2Duo SU7300 - Hybrid Intel GMA & Nvidia G210M - 4 GB DDR3 RAM - Win7 Home Premium 64 bit.

Hope that helps.

comment:3 by bluegr, 9 years ago

I didn't get any crash on the CD version, though the credits scene seems that it updates the screen without getting user input, thus no system events are monitored. This means that the ScummVM window can't be moved, or switched to etc

comment:4 by bluegr, 9 years ago

Owner: set to bluegr

comment:5 by bluegr, 9 years ago

The freezing and unresponsiveness that you experienced should be fixed in the latest daily version (rev 54395), I tried both the CD and floppy versions, and they play file.

I haven't seen any error about a missing picture resource. Are you sure you copied over all of the game's files?

comment:6 by bluegr, 9 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:7 by bluegr, 9 years ago

Status: newpending

comment:8 by (none), 9 years ago

I'm sorry, where's the link for the latest win x64 builds? I've been looking everywhere and cannot find it.

comment:9 by (none), 9 years ago

Status: pendingnew

comment:10 by (none), 9 years ago

Had to stick with the win32 build for now, since it's the only available link on main download site. The ending credit on CD version are now playing correctly. But the floppy version still has "ERROR: picture resource 680 not found!". Either that, or my original copy really have missing file(s). Any advice?

comment:11 by bluegr, 9 years ago

You can get the windows 64 one here:
http://buildbot.scummvm.org/snapshots/trunk/

I don't know about the missing picture resource, it seems like your game data files are damaged, my version works fine... :(

comment:12 by (none), 9 years ago

If it's ok: could you find out which file contains that missing resource data?

Anyway, you can close this case now.

Thx 4 ur help. :D

comment:13 by bluegr, 9 years ago

I believe that it's resource.000 or resource.001

Closing then, thanks for your feedback!

comment:14 by bluegr, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.