Opened 9 years ago

Closed 9 years ago

Last modified 13 months ago

#5486 closed defect (fixed)

LOL: Vaelan's Cube can be duplicated at Scotia's Barrier

Reported by: SF/shurlogg Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: script Cc:
Game: Lands of Lore

Description

ScummVM version: Win32 Daily SVN 2010-10-30

Bug details, including instructions on reproducing it:
1. In front of Scotia's first barrier (Upper Opinwood), equip Vaelan's Cube as a weapon
2. Attack the barrier with the character that has the cube
Expected result: The Vaelan's Cube (in the character's weapon slot) changes color
Actual result: The mouse cursor changes second Vaelan's Cube with the opposite color. This duplicate cube can be placed in the inventory and used later. The procedure can be repeated multiple times, because the integrity of the barrier is not affected.

Reproducibility: 10/10

Language of game: English
Version of game: Floppy
Platform and Compiler: Win32, unknown compiler (downloaded from ScummVM site)

Attachment: Save game

Ticket imported from: #3098935. Ticket imported from: bugs/5486.

Attachments (1)

lol.006 (25.1 KB ) - added by SF/shurlogg 9 years ago.
Save game before barrier, main character holding cube

Download all attachments as: .zip

Change History (6)

by SF/shurlogg, 9 years ago

Attachment: lol.006 added

Save game before barrier, main character holding cube

comment:1 by athrxx, 9 years ago

I could reproduce this one. This happens in early (unpatched) DOS floppy versions only. The problem here is that you simply should not be able to equip the cube as a weapon.

The bug is fixed in this official patch:
ftp://ftp.westwood.com/pub/lands1/updates/lolus123.exe

Nonetheless, I have also added a workaround since ScummVM users should not need to apply patches if it can be avoided. The cube can't be equipped in the weapn slot any more.

It would be welcome if you could play through this game version without applying the official patch. There might be more bugs like this for which I'd like to add workarounds.

comment:2 by athrxx, 9 years ago

Owner: set to athrxx

comment:3 by SF/shurlogg, 9 years ago

No problem, I will leave the game unpatched and look out for any other glitches.

comment:4 by athrxx, 9 years ago

Resolution: fixed
Status: newclosed

comment:5 by digitall, 13 months ago

Component: Engine: Kyra
Game: Lands of Lore
Note: See TracTickets for help on using tickets.