Opened 9 years ago

Closed 9 years ago

Last modified 13 months ago

#5485 closed defect (invalid)

LOL: Tower Sub-level is unsolvable

Reported by: SF/shurlogg Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: script Cc:
Game: Lands of Lore

Description

ScummVM version: Win32 Daily SVN 2010-10-30

Bug details, including instructions on reproducing it:
1. Enter the Tower sub-level
2. Pick up one of the five items moving around on the floor
3. Place item in one of the five niches
4. Repeat steps 2 and 3 for the other four items
Expected result: The niches disappear, it is possible to enter the next room
Actual result: The niches remain, when entering the next room the party is teleported away (just like when the puzzle is not solved correctly)

Reproducibility: 10/10

Language of game: English
Version of game: Floppy
Platform and Compiler: Win32, unknown compiler (downloaded from ScummVM site)

Attachment: Save game

Ticket imported from: #3098918. Ticket imported from: bugs/5485.

Attachments (1)

lol.009 (26.5 KB ) - added by SF/shurlogg 9 years ago.
Save game just before Tower Sub-level

Download all attachments as: .zip

Change History (6)

by SF/shurlogg, 9 years ago

Attachment: lol.009 added

Save game just before Tower Sub-level

comment:1 by athrxx, 9 years ago

I cannot reproduce this bug with your savegame. It worked jus fine for me.

If I solve the riddle correctly (placing all items *except the poison dart* in the 4 niches) the niches will close and I can walk through the next room, unlock the door etc.

If I don't solve the riddle correctly the niches won't close and I will teleported back. This is the behaviour ypu describe as "Actual result" so I presume you simply did not solve the riddle correctly (maybe placed the poison dart).
Could this be the case? ;-)

comment:2 by athrxx, 9 years ago

Owner: set to athrxx

comment:3 by SF/shurlogg, 9 years ago

Resolution: invalid
Status: newclosed

comment:4 by SF/shurlogg, 9 years ago

You're right, I got the puzzle wrong - when I left the poison dart lying around and placed the other 4 items, the niches closed and I was able to continue. => Closing this entry as invalid.

comment:5 by digitall, 13 months ago

Component: Engine: Kyra
Game: Lands of Lore
Note: See TracTickets for help on using tickets.