Opened 9 years ago

Closed 9 years ago

#5481 closed defect (fixed)

T7G-RUS: crash on start

Reported by: SF/lubomyr_ua Owned by: jvprat
Priority: normal Component: Engine: Groovie
Keywords: Cc:
Game: 7th Guest

Description

ScummVM version 1.2.053093
ScummVM version 1.3.0svn53822
Bug details:
Crash on start
User picked target 't7g-ru' (gameid 'groovie')...
Looking for a plugin supporting this gameid... Groovie Engine
Starting 'Groovie engine game'
Groovie::T7GFont: Glyph 0 starts at 202 but the current offset is 182!

Language of game: Russian
Version of game: CD
Platform: All

with old 1.1.1 (1.1.148874) release works ok.

Ticket imported from: #3095031. Ticket imported from: bugs/5481.

Attachments (1)

t7g_rus.jpg (43.6 KB ) - added by SF/lubomyr_ua 9 years ago.

Download all attachments as: .zip

Change History (5)

by SF/lubomyr_ua, 9 years ago

Attachment: t7g_rus.jpg added

comment:1 by digitall, 9 years ago

I don't have t7g-ru, so can't bisect myself, but this is likely to be a regression of :
r49487 | jvprat | 2010-06-07 18:14:42 +0100 (Mon, 07 Jun 2010) | 6 lines

Groovie:
- Rewritten T7G's font code to subclass Graphics::Font and make it cleaner.
- Use theme fonts for the Mac version of T7G (which used ugly system fonts
originally). With this the Mac version should be completable.
- Cleanup include interdependencies.

comment:2 by jvprat, 9 years ago

Owner: set to jvprat

comment:3 by jvprat, 9 years ago

Resolution: fixed
Status: newclosed

comment:4 by jvprat, 9 years ago

I've fixed this in r53874 (trunk) and r53875 (branch-1.2). Since I don't own the Russian version, it would be nice if you could verify there's no issue with the font rendering. It's only used for the savegame names in the save/load menus inside the game (not the ScummVM ones).
Thanks for reporting!

Note: See TracTickets for help on using tickets.