Opened 9 years ago

Closed 3 years ago

#5471 closed defect (fixed)

SCI: QFG1 EGA - Hangs after hitting bird's nest with rock

Reported by: (none) Owned by: m-kiewitz
Priority: low Component: Engine: SCI
Keywords: original Cc:
Game: Quest for Glory 1

Description

Started a game, left town, went north.

1) move to tree
2) get rocks
3) move to right side of screen by the hut
4) throw rock at birds nest
5) when a rock hits the nest, the character moves to the nest automatically to retrieve the ring

Game hangs at this point with the wait cursor.

Ticket imported from: #3092694. Ticket imported from: bugs/5471.

Change History (16)

comment:1 by m-kiewitz, 9 years ago

i just tried, works for me in the original hero's quest. I cant try it in the renamed QfG, because I don't own that one.

Probably also try with latest daily build just to make sure

comment:2 by m-kiewitz, 9 years ago

Resolution: worksforme

comment:3 by m-kiewitz, 9 years ago

i tried on hero's quest interpreter version 0.000.566, game version 1.000
lskovlun tried on quest for glory 1 interpreter version 0.000.629, game version 1.200

in both of those the bug didn't occur

could you please check, which interpreter version you got and post that information here?

comment:4 by (none), 9 years ago

"About Glory I" says version 1.200. How do I find the interpreter version?

comment:5 by (none), 9 years ago

Nevermind, ran strings on the binary and it says 0.000.629.

I'm having this problem with scummvm v1.2.0. I'll try the daily build.

comment:6 by (none), 9 years ago

Hrm, I think it's timing/animation speed dependent. I reproduced it twice before reporting it and now I can't reproduce with 1.2.0 or the daily build.

comment:7 by bluegr, 9 years ago

I just tried this on QFG1, and didn't get any hang either (using the daily build).

What is your operatins sytem? Is it 32 or 64 bit? What sound settings are you using in ScummVM? (i.e. are you using Adlib, MT-32...?)

comment:8 by (none), 9 years ago

I'm using Ubuntu 10.10 64-bit. Default sound settings which I believe is MT-32 emulator.

comment:9 by bluegr, 9 years ago

I'm using Windows 7 64-bit, I've tried Adlib, GM and MT-32 with the same version of QFG1 as yours to reproduce this bug but I can't. I've tried normal game speed, and fastest game speed.

I guess it's a script/timer related bug then, which is more likely as it doesn't always occur. I'm therefore lowering the priority of this to 1, same as the other timer related script bugs, which are hard to reproduce and don't always occur.

(btw, I've asked about the sound settings, as SCI scripts sometimes sync game animations with sound, which could explain a lockup with certain sound configurations, as the music / sound scores differ for each sound card)

comment:10 by bluegr, 9 years ago

Keywords: original added
Priority: normallow

comment:11 by bluegr, 9 years ago

Moving to the wiki, known SCI bugs page:
http://wiki.scummvm.org/index.php/SCI/Bugs

comment:12 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed

comment:13 by m-kiewitz, 4 years ago

Summary: QFG1 EGA - Hangs after hitting bird's nest with rockSCI: QFG1 EGA - Hangs after hitting bird's nest with rock

comment:14 by m-kiewitz, 4 years ago

Does this bug still occur?
I added a script patch on 31.10.2014 against a bird's nest issue, which was quite similar and happened when running and then throwing rocks.

comment:15 by m-kiewitz, 4 years ago

Status: closedpending

comment:16 by sev-, 3 years ago

Owner: changed from bluegr to m-kiewitz
Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.