Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5457 closed defect (fixed)

RTZ: Keyboard unresponsive

Reported by: SF/blueberrymobile Owned by: bluegr
Priority: normal Component: Engine: MADE
Keywords: Cc:
Game: Return to Zork

Description

System:
ScummVM 1.2.0, Windows, English.

I'm not sure if this bug has occurred before, this is the first time I've tried playing Return to Zork on ScummVm, but when in the game, keyboard input doesn't do anything. I can't skip cut scenes and I can't open the Scumm menu in game. Mouse clicks seem to work fine. I believe I'm running the CD version of the game, it's been a long time since I put it on my hard drive.
Thanks!

Ticket imported from: #3090034. Ticket imported from: bugs/5457.

Change History (4)

comment:1 by digitall, 9 years ago

Have checked this against previous versions of ScummVM and it does not appear to be
a regression.

However, ScummVM's MADE Engine implementation does not implement some
of the keyboard shortcuts of the original IBM DOS interpreter, specifically :
F1: Open Zork System Menu
F2: Quick Save
F3: Quick Load
F4: Repeat Last Screen Message
Cursor Keys / Numeric Keypad : Control Pointer with Keyboard
Plus = Right Mouse Button
Minus = Left Mouse Button
Spacebar = Skip Cutscenes

However the game is playable :
ScummVM System Menu is available via CTRL-F5.
ESC skips cutscenes (where possible e.g. Infocom Logo is not skippable)
Zork System Menu is accessed by moving the mouse to the top left corner of the screen.
Right Click opens the inventory.

comment:2 by fingolfin, 9 years ago

Owner: set to johndoe123

comment:3 by bluegr, 9 years ago

Fixed in r54568

comment:4 by bluegr, 9 years ago

Owner: changed from johndoe123 to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.