Opened 9 years ago

Closed 8 years ago

Last modified 7 months ago

#5452 closed defect (fixed)

MIDI and MT-32 don't use defaults

Reported by: SF/l-w-c Owned by: athrxx
Priority: normal Component: Audio: MT32
Keywords: Cc:
Game:

Description

Unlike every other setting that has an option called "<default>", MIDI and MT-32 are set to specific settings instead.

Ticket imported from: #3088438. Ticket imported from: bugs/5452.

Attachments (3)

midi.jpg (12.8 KB) - added by SF/l-w-c 9 years ago.
Where's the default when selecting a value?
mt-32.jpg (13.1 KB) - added by SF/l-w-c 9 years ago.
Where's the default when selecting a value?
audio.jpg (17.3 KB) - added by SF/l-w-c 9 years ago.
Other audio devices do have a "default" in the selection box

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by jvprat

Owner: set to athrxx

comment:2 Changed 9 years ago by athrxx

The launcher controls have now been changed. There are new default settings ("Don't use GM/MT-32 music") which should avoid the use of some unwanted MIDI device. Does this address your issue?

Changed 9 years ago by SF/l-w-c

Attachment: midi.jpg added

Where's the default when selecting a value?

Changed 9 years ago by SF/l-w-c

Attachment: mt-32.jpg added

Where's the default when selecting a value?

Changed 9 years ago by SF/l-w-c

Attachment: audio.jpg added

Other audio devices do have a "default" in the selection box

comment:3 Changed 9 years ago by SF/l-w-c

I don't think we're talking about the same thing. Compare the the 3 screenshots. Only one of them has "default" as a selectable value.

comment:4 Changed 9 years ago by athrxx

Okay, I made another change here. The launcher controls now shoudn't jump to the first available devices (usually the MT-32 emulator for MT-32 and the first MIDI device for GM). Instead, they will use the first list entries as defaults ("Don't use MT32/GM music").

This means that with "preferred device" (or "music device" in the individual target options) set to <default> you won't get MIDI music unless you make specific choices in the MIDI and MT-32 tabs.
Main reason for that change is that people would get the MT-32 emulator by default for certain games (Indy 4, Monkey Island 2) which really isn't the desired behaviour.

The former "<default>" settings of the MIDI and MT-32 tabs have been renamed to "Use first available device" to make things a bit less confusing.

comment:5 Changed 9 years ago by SF/l-w-c

Please attach screenshots.

comment:6 Changed 9 years ago by bluegr

Why should these two pulldown menus have a "<default>" option? Such an option doesn't make sense for these two.

GM Device: you have the following options:
- Don't use General MIDI music
- Use first available device
- Windows MIDI (for Windows, there could be others in other systems)

- MT-32 Device: you have the following options:
- Don't use Roland MT-32 music
- Use first available device
- Windows MIDI (or Windows, there could be others in other systems)
- MT-32 emulator

The options are pretty self explanatory. A "default" setting doesn't make sense, and would be quite confusing. The "default" value is "Use first available device", which is pretty self-explanatory, compared to just a simple "Default" option

comment:7 Changed 8 years ago by bluegr

Status: newpending

comment:8 Changed 8 years ago by bluegr

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:9 Changed 8 years ago by SF/l-w-c

Looking at it again, I need to rephrase. Those two settings DO have a setting called "<default>". The problem is it's not actually the default choice. I say if you call it default, it should therefore be the default. Otherwise it makes no sense.

comment:10 Changed 8 years ago by SF/l-w-c

Status: pendingnew

comment:11 Changed 8 years ago by SF/l-w-c

Sorry, please delete my last comment.

thebluger, if athrxx renamed like he said he did (I wish he would have agreed to post screenshots), then you're talking about something that's not there anymore.

comment:12 Changed 8 years ago by athrxx

I close this item since this has long been fixed.

comment:13 Changed 8 years ago by athrxx

Resolution: fixed
Status: newclosed

comment:14 Changed 7 months ago by digitall

Component: Audio: MT32
Note: See TracTickets for help on using tickets.