Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5407 closed defect (fixed)

LB2CD: Problems with scaling

Reported by: bluegr Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

There are some problems with scaling in LB2CD, in one of the museum screens (room 370 - to the right of the colossal Egyptian bust).

Some people in the background are scaled to be too big.
Screenshot (also attached): http://img97.imageshack.us/img97/5097/lb2cdscaling.png
It should look like this: http://www.youtube.com/watch?v=58PzgQSMmvI#t=6m17s
(the actors are random)

Not sure if this also happens with the floppy version, haven't tried it

Ticket imported from: #3083577. Ticket imported from: bugs/5407.

Attachments (2)

laurabow2-cd.003 (49.2 KB) - added by bluegr 9 years ago.
Saved game
lb2cd-scaling.png (155.3 KB) - added by bluegr 9 years ago.
Screenshot of the problem (resized because of SF's file size restrictions)

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by bluegr

Attachment: laurabow2-cd.003 added

Saved game

Changed 9 years ago by bluegr

Attachment: lb2cd-scaling.png added

Screenshot of the problem (resized because of SF's file size restrictions)

comment:1 Changed 9 years ago by bluegr

Sorry, attaching additional missing details:
Using WinXP and Win7
Game is LB2CD English
ScummVM r53067, built with VS2010

Happens with both the trunk and branch 1.2.0

It seems as if scaling is done inversely, i.e. actors are getting bigger instead of getting smaller

comment:2 Changed 9 years ago by bluegr

Update from m_kiewitz: this is a regression from revisions 52887 & 52888

comment:3 Changed 9 years ago by m-kiewitz

fixed in r53068

comment:4 Changed 9 years ago by m-kiewitz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.