Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5403 closed defect (duplicate)

LSL2 Crashes (GfxPort Error)

Reported by: SF/b1100101 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 2

Description

While playing Larry2 the console opened and shows this error message: "GfxPorts::kernelSetActive was requested to set invalid port id 3!"

Trying to load my last save file gives me the same error (save file in attachment)

LSL2 Version 1.002.000 (DOS/English)
Mac OS X 10.6.4 (32bit)
ScummVM 1.30svn53037 (Oct 6 2010 4:35:10) (latest Nightly Build, happened on build from Oct 3rd too)

Ticket imported from: #3082494. Ticket imported from: bugs/5403.

Attachments (1)

lsl2.009.zip (16.7 KB) - added by SF/b1100101 9 years ago.
Savegame which gives me the crash on load

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by SF/b1100101

Attachment: lsl2.009.zip added

Savegame which gives me the crash on load

comment:1 Changed 9 years ago by bluegr

Did you try to save while a speech window is up?

comment:2 Changed 9 years ago by SF/b1100101

@thebluegr
No, it seems like I saved during a scripted event (I didn't know the script is still running when I saved). I was able to play after save the game for about an minute or so, then it gave me the error, then loading the save resulted in the same error.

comment:3 Changed 9 years ago by bluegr

The crash occurs because you saved while a speech window was up (in this case, the cutscene's). This is a duplicate of bug #3064899, I do have a fix for it but I'm just waiting for some feedback from m_kiewitz on it. Closing this as duplicate

comment:4 Changed 9 years ago by bluegr

Owner: set to bluegr
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.