Opened 9 years ago

Closed 3 years ago

Last modified 3 years ago

#5397 closed defect (fixed)

AGI Mother Goose: No text in speech bubble

Reported by: eriktorbjorn Owned by: m-kiewitz
Priority: high Component: Engine: AGI
Keywords: Cc:
Game: Mixed-Up Mother Goose

Description

Current ScummVM trunk
English version of the game. (From the Roberta Williams Anthology)

When I approach the boy standing at the fireplace, there's a speech bubble but there's no text in it. It's supposed to say "Boy, am I hungry for pie!". The bug does not happen in DOSBox, nor in NAGI.

Ticket imported from: #3080030. Ticket imported from: bugs/5397.

Attachments (1)

mixedup.000 (5.1 KB) - added by eriktorbjorn 9 years ago.
I hope this is the right savegame

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by eriktorbjorn

Attachment: mixedup.000 added

I hope this is the right savegame

comment:1 Changed 8 years ago by sev-

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:2 Changed 8 years ago by sev-

Owner: set to sev-
Priority: normalhigh

comment:3 Changed 8 years ago by eriktorbjorn

Someone - I forget who - asked me the other day if this still happens. (He wasn't there by the time I saw the message and wanted to reply, and an unexpected reboot made me lose it.) It does, at least for me.

comment:4 Changed 8 years ago by sev-

Owner: sev- deleted

comment:5 Changed 6 years ago by uruk

There are no texts at all in any speech bubbles in the game.

comment:6 Changed 6 years ago by uruk

I looked deeper into it, and the problem is the same as wjp described in a comment: https://sourceforge.net/tracker/?func=detail&aid=3292787&group_id=37116&atid=418820
When all of the lines of the text in the speech bubble is displayed, the game overwrites them with a blank speech bubble before the player could read the text.
I am not sure how to fix it. Hope someone with better understanding of the AGI engine can solve it.

comment:7 Changed 3 years ago by m-kiewitz

Owner: set to m-kiewitz

comment:8 Changed 3 years ago by m-kiewitz

this bug seems to be solved in my current work-in-progress graphics rewrite.
Marking for later.

comment:9 Changed 3 years ago by m-kiewitz

Resolution: fixed
Status: newclosed

comment:10 Changed 3 years ago by m-kiewitz

This is now fixed by commit 8a595e7771aa89d06876e13d7ab6751e26da8982

Note: See TracTickets for help on using tickets.