Opened 9 years ago

Closed 9 years ago

Last modified 12 months ago

#5385 closed defect (invalid)

WIN: Fullscreen minimizes constantly

Reported by: SF/yushatak Owned by: Kirben
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

When I start ScummVM (either the game choosing menu or directly into a game) it refuses to stay maximized. This only occurs in fullscreen mode. If I alt-tab back to the game/menu it stays up for a second, not long enough to do anything, and then minimizes itself again.

This makes it unusable (unless you prefer windowed mode - I do not).

This happens in 1.0 and 1.1.1 32-bit and 64-bit.

Ticket imported from: #3074149. Ticket imported from: bugs/5385.

Change History (17)

comment:1 by SF/yushatak, 9 years ago

Priority: normalblocker

comment:2 by SF/yushatak, 9 years ago

Summary: Fullscreen Minimizes Constantly on Win7-64Fullscreen Minimizes Constantly on Win7-64 Service Pack 1

comment:3 by salty-horse, 9 years ago

Priority: blockernormal

comment:4 by SF/yushatak, 9 years ago

Clarification: If ScummVM is set up to run in Fullscreen mode it happens without doing anything but running the program - immediate minimization without any action.

comment:5 by SF/yushatak, 9 years ago

Further clarification: For a brief moment the game or ScummVM UI shows up just fine, but then it minimizes. This is not an issue with the resolution, as it's displayed just fine for that brief moment.

comment:6 by SF/yushatak, 9 years ago

Problem magically resolved itself, so it seems it's intermittent or caused by some as-yet unknown factor. Nothing has changed in my configuration, even running programs. I have not rebooted, etc.

comment:7 by m-kiewitz, 9 years ago

Resolution: worksforme
Status: newclosed

comment:8 by lordhoto, 9 years ago

I do not think this is a bug of ScummVM. I found some other refrences to this on the web:

http://www.vistax64.com/vista-games/222648-fullscreen-games-minimize-tray-automatically.html
and
http://social.answers.microsoft.com/Forums/en-US/vistagaming/thread/9092c395-dfdb-4f3d-b797-2ca1b0e073ec

for example.

Most interesting thing I found via a quick search via google was this though:

http://support.mozilla.com/tiki-view_forum_thread.php?comments_offset=0&comments_threadId=0&comments_parentId=653645&comments_threshold=0&thread_sort_mode=commentDate_asc&forumId=1&time_control=3600

Do you have Firefox open when trying to use ScummVM in Fullscreen just by chance?

comment:9 by lordhoto, 9 years ago

Resolution: worksforme
Status: closednew

comment:10 by lordhoto, 9 years ago

Summary: Fullscreen Minimizes Constantly on Win7-64 Service Pack 1WIN: Fullscreen minimizes constantly

comment:11 by Kirben, 9 years ago

Resolution: invalid
Status: newclosed

comment:12 by Kirben, 9 years ago

Closing again, there is clearly not a ScummVM issue.

comment:13 by lordhoto, 9 years ago

Owner: set to Kirben

comment:14 by m-kiewitz, 9 years ago

I got this e-mail today from "yushatak@users.s0urcef0rge.net". I replied to yushatak, but I got a delivery failure.
I don't have anything to do with this bug, so I won't reopen it.

--------------------

Just because *you* don't have this problem doesn't mean that
it isn't a probem. I am not some technically illiterate
fool, I submitted this bug after hours of testing, attempted
fixes, and consultation with the IRC channel.

Please re-open this bug, as it has returned for me and will
continue to be an intermittent problem for me and who knows
how many others once Win7 SP1 is out of beta.

comment:15 by Kirben, 9 years ago

To clarify, this problem would be caused by programs/services you have running in the background, and not ScummVM.

Don't expect any support for a beta operating system (Windows 7 SP1) either.

comment:16 by Kirben, 9 years ago

Component: --Unset--

comment:17 by digitall, 12 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.