Opened 17 years ago

Closed 17 years ago

#538 closed defect (fixed)

DIG: Unwanted scrolling

Reported by: SF/andrej4000 Owned by: eriktorbjorn
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

The Dig, english version

If you stand in the Nexus and you start talking to brink
through communicator, the windows is "scrolled" to
another position in the nexus and makes it impossible
after the talk to do anything else in the room...

savegame attached

Ticket imported from: #634541. Ticket imported from: bugs/538.

Attachments (1)

dig.s07 (166.8 KB ) - added by SF/andrej4000 17 years ago.
Screwed up game

Download all attachments as: .zip

Change History (14)

by SF/andrej4000, 17 years ago

Attachment: dig.s07 added

Screwed up game

comment:1 by SF/andrej4000, 17 years ago

Priority: normalhigh
Summary: DIG: communicationDIG: communication screws up the game

comment:2 by fingolfin, 17 years ago

From bug #636303:
When the landing team leaves the Space Shuttle for the
first time in order to inspect the meteor, opening the
inventory and using the flashlight on the meteor causes
the screen to scroll to the left, all the way back to the
Space Shuttle.

I think I found another place where the problem is visible:
when you move down using that triangular "elevator"
(going
to the dead alien in the pyramid), then once the cut scene
part ends (elevator moving down etc.), then the in-game
scene is moved to much to the left - it doesn't give a
seamless transition from the cut scene to the normal game play.

comment:3 by fingolfin, 17 years ago

Summary: DIG: communication screws up the gameDIG: Unwanted scrolling

comment:4 by fingolfin, 17 years ago

* I can't reproduce the nexus/communicator/brinks bug - do
you still get it with latest CVS?

* the bug near the start doesn't even require the
flashlight: when you are on the screen overviewing the
asteroid, showing the inventory then hiding it again causes
the scrolling.
What happens is that panCameraTo(0,0) is called. Not sure
why that would be done now, though.

comment:5 by SF/bugzapper, 17 years ago

If you want to trigger this nearly anywhere the screen can
scroll just right-click on where you'd normally left click to
scroll the screen and move in the direction. What happens is
the inventory opens and when you close it the screen scrolls
without the actors.

This can cause some interesting side effects. Like if you fly
your team to the asteroid and then right-click to scroll the
screen back to the shuttle. Then click by the shuttle, after a
short wait your miniaturized crew will fly over as they never
scaled back up to the proper size.

comment:6 by fingolfin, 17 years ago

Owner: set to SF/ender

comment:7 by fingolfin, 17 years ago

It would see right mouse is incorrectly triggering left mouse effects... ender, any idea on this one?

comment:8 by fingolfin, 17 years ago

No time to investigate this right now, but maybe the code in verbs.cpp, checkExecVerbs(), is not 100% correct for The Dig and that's the reason. Might be useful to check that against disassmbly <shrug>.

comment:9 by fingolfin, 17 years ago

Erik talked about this one in a patch...

comment:10 by fingolfin, 17 years ago

Owner: changed from SF/ender to eriktorbjorn

comment:11 by eriktorbjorn, 17 years ago

It could be the same bug as the one described in bug #716350
("DIG: Can't exit room!") and patch #733099 ("DIG:
Experimental camera fix"). I didn't make the connection
until you pointed it out though.

comment:12 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed

comment:13 by fingolfin, 17 years ago

Fixed by Erik in CVS (note: the windows daily builds won't reflect this
till roughly monday/tuesday).

Note: See TracTickets for help on using tickets.