Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5369 closed defect (duplicate)

MMNES: Crash After Ed Leaves if in His Room Before Doorbell

Reported by: SF/jennibee Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: original Cc:
Game: Maniac Mansion

Description

If you are in Ed's Room Before the Doorbell rings, the cutscene will change from the one where Ed interrogates you after catching you, to the one where he's excited because the doorbell rang. You will be left in his room, and if you try to interact with the room or leave, ScummVM will crash with "ERROR: (26:89:0xF) Invalid actor 255 in o2_putActorInRoom.

I used Linux (Ubuntu x86 32-bit) 1.3.0svn52786.

Ticket imported from: #3069656. Ticket imported from: bugs/5369.

Attachments (1)

maniac-nes-us.s01 (6.8 KB ) - added by SF/jennibee 9 years ago.
In Ed's Room Before the Doorbell

Download all attachments as: .zip

Change History (6)

by SF/jennibee, 9 years ago

Attachment: maniac-nes-us.s01 added

In Ed's Room Before the Doorbell

comment:1 by SF/jennibee, 9 years ago

My Maniac Mansion version was NES/English (US).

comment:2 by sev-, 9 years ago

Owner: set to Kirben

comment:3 by sev-, 9 years ago

Kirben, could you please take a look?

comment:4 by fingolfin, 9 years ago

This is a duplicate of bug #1447058, which I fixed in December 2010 for the PC version. Using the savegame attached here, I just verified that my fix from then also applies to the NES version.

comment:5 by fingolfin, 9 years ago

Keywords: original added
Owner: changed from Kirben to fingolfin
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.