Opened 9 years ago

Closed 9 years ago

#5364 closed defect (fixed)

SQ2: ScummVM hanging on the inventory screen

Reported by: SF/escarlate Owned by: digitall
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

When playing in windowed mode, ScummVM hangs if the player tries to close the window while the inventory screen is being displayed.

Game: Space Quest 2
Game Version: 2.0A 1987-11-06 3.5''/DOS/English
ScummVM Version: 1.2.0svn52740
OS: Win32 (XP SP2)

Ticket imported from: #3067263. Ticket imported from: bugs/5364.

Change History (6)

comment:1 Changed 9 years ago by eriktorbjorn

I can't reproduce this with the Linux version. Does it happen every time?

comment:2 Changed 9 years ago by SF/escarlate

Yes.

comment:3 Changed 9 years ago by digitall

I have replicated this with V2.0F on Linux.

Though I can find no issue closing ScummVM while displaying the normal inventory screen i.e.
<Tab> or Menu ->Action->Inventory, this occurs when displaying the object examination Inventory i.e.
<F4> or Menu->Action->See Object, where upon ScummVM will not exit and has to be killed from ps.

Will try to locate the cause..

comment:4 Changed 9 years ago by digitall

Traced to !exit_select loop in AgiEngine::selectItems(int n) (inv.cpp:113)
Looks like this is missing shouldQuit() || _restartGame qualification.
Will test a patch, then commit.

comment:5 Changed 9 years ago by digitall

Owner: set to digitall
Resolution: fixed
Status: newclosed

comment:6 Changed 9 years ago by digitall

Fixed in ScummVM 1.3.0svn52856

Note: See TracTickets for help on using tickets.