Opened 9 years ago

Closed 9 years ago

#5359 closed defect (fixed)

GOB: Gobliiins not moving

Reported by: SF/theint Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliiins

Description

In the 9th screen (code ICVGCGT) if you stay with as little energy as possible and you try to give the meat while the dog is barking, the GO button appears but you also lose. After that if you press AGAIN the game resets just fine but the goblins won't listen to your mouse clicks.

ScummVM 1.2.0svn (Sep 13 2010 08:08:55)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ RGB zLib

English version of the game using scummvm in Gentoo linux

Ticket imported from: #3065914. Ticket imported from: bugs/5359.

Change History (7)

comment:1 Changed 9 years ago by jvprat

Owner: set to DrMcCoy
Summary: Gobliiins not movingGOB: Gobliiins not moving

comment:2 Changed 9 years ago by digitall

This sounds very similar to the "UOTODDV" issue noted in bug #3018918 and corrected :
http://sourceforge.net/tracker/?func=detail&aid=3018918&group_id=37116&atid=418820

I will see if this issue like that one was present in the original interpreter.

comment:3 Changed 9 years ago by digitall

Hmm... I can't replicate this with my Windows ADI version of Gob1, but this is because the screen after "GAME OVER" only has "LOAD" and "EXIT", not "AGAIN" and I can't replicate this issue with LOADING in ScummVM HEAD.

DrMcCoy : Can you replicate?

comment:4 Changed 9 years ago by digitall

Replicated with ADI Win Gob1 with ScummVM 1.3.0svn52848.
Strangerke has also managed this with EGA Floppy in ScummVM.

Giving the meat to the dog after the lose animation has started seems to trigger this effect..

comment:5 Changed 9 years ago by digitall

I have managed to reproduce the same giving meat when GO already shown i.e. lose and GO with original interpreter, but the gobliins are not stuck on LOAD.. though the second try did give a GPF, so this may be the manifestation of the same issue.

comment:6 Changed 9 years ago by digitall

Should be fixed in r54061.

comment:7 Changed 9 years ago by digitall

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.