Opened 9 years ago

Closed 9 years ago

Last modified 13 months ago

#5351 closed defect (duplicate)

SCUMM: Wrong charset used when pressing pause key

Reported by: SF/simsaw Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

When pressing SPACE in a SCUMM game that supports pausing by this key, it displays a message like "Game paused. Press SPACE to continue." When using this key in a localised version that uses special letters like German "umlaute", then these affected letters are not correctly displayed. So in the German version of Monkey Island 2 it would display
"Spielpause. Dr cken Sie die Leertaste."
instead of
"Spielpause. Drücken Sie die Leertaste."
The ü is clearly missing.
This seems to happen because SCUMM games use their own charset. I'm not sure if it's ASCII but it is different from ANSI for sure. ScummVM probably tries using the ANSI charset here which doesn't work.

Tested with Daily Build from September, 11 2010.

Ticket imported from: #3064656. Ticket imported from: bugs/5351.

Change History (3)

comment:1 by sev-, 9 years ago

Owner: set to sev-
Resolution: duplicate
Status: newclosed

comment:2 by sev-, 9 years ago

This is duplicate of #1946611

comment:3 by digitall, 13 months ago

Component: Engine: SCUMM
Game: Monkey Island 2
Note: See TracTickets for help on using tickets.