Opened 17 years ago

Closed 17 years ago

#534 closed defect (duplicate)

MI1: MP3 decoding error

Reported by: SF/andrej4000 Owned by: SF/khalek
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

I get the bug with the CVS snapshot from 5th
November.

The bug occurs in that way:
(MP3 is used)

1) you save a game while MP3-music is playing
2) you quit ScummVM
3) you start ScummVM again and load the savegame

then ScummVM says "MP3 decoding error" the whole
time.
you have to enter a room with another music track to
stop this, after this all music is plaey normal again.

Ticket imported from: #634028. Ticket imported from: bugs/534.

Change History (6)

comment:1 by SF/andrej4000, 17 years ago

Summary: MONKEY!: MP3 decoding errorMONKEY1: MP3 decoding error

comment:2 by eriktorbjorn, 17 years ago

I think the "MP3 decoding error" messages happen because
ScummVM isn't properly told to stop playing the current
music before restoring a saved game. That should be easy
enough to fix.

Ideally we should also resume the music that was being
played when the savegame was made, but I don't think we
store that information, so that would have to wait for the
new savegame format. (Will that really happen before 0.3.0
is released, like the milestone page says?)

comment:3 by fingolfin, 17 years ago

We won't have a new save game format in 0.3.0, I'll fix that
page

comment:4 by fingolfin, 17 years ago

Summary: MONKEY1: MP3 decoding errorMI1: MP3 decoding error

comment:5 by SF/khalek, 17 years ago

Owner: set to SF/khalek
Resolution: duplicate
Status: newclosed

comment:6 by SF/khalek, 17 years ago

this is a duplicate of 590069 ALL: mp3 bug when loading a
save game
closing

Note: See TracTickets for help on using tickets.