Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5328 closed defect (fixed)

LSL5: Patty sprite shown upside-down outside of club

Reported by: OmerMor Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 5

Description

Game version: EGA/DOS/1.000 09/24/91
ScummVM version: 1.2.0svn52511
Platform: Windows7 32bit

Problem: As Patty, after you first leave the Piano Pit night-club, the sprite of Patty is shown upside-down.
Attached screenshot & savegame.

Ticket imported from: #3059336. Ticket imported from: bugs/5328.

Attachments (2)

lsl5ega - upside_down.png (98.7 KB ) - added by OmerMor 9 years ago.
lsl5-1.006 (22.1 KB ) - added by OmerMor 9 years ago.

Download all attachments as: .zip

Change History (7)

by OmerMor, 9 years ago

Attachment: lsl5ega - upside_down.png added

by OmerMor, 9 years ago

Attachment: lsl5-1.006 added

comment:1 by m-kiewitz, 9 years ago

Summary: LSL5: Patty sprite shown upside-down outside of clubLSL5EGA: Patty sprite shown upside-down outside of club

comment:2 by m-kiewitz, 9 years ago

happens in VGA as well
is a regression of r52467, although i think it's actually the same issue as laura bow turning into a boiler (bug #3050602) and it wasn't shown before because of different timing in kInitBresen/kDoBresen

wrong loop is also set by StopWalk::doit in exactly the same spot as in laura bow 2 CD

comment:3 by m-kiewitz, 9 years ago

Summary: LSL5EGA: Patty sprite shown upside-down outside of clubLSL5: Patty sprite shown upside-down outside of club

comment:4 by m-kiewitz, 9 years ago

fixed in r52531

comment:5 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.