Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5322 closed defect (duplicate)

SQ5: Crashes on load BattleCruiser game

Reported by: SF/negativeiq Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Space Quest 5

Description

I saved the game at the beginning of the Battle Cruiser mini game against Quirk in the Space Bar. Later I attempted to restore this game.
After restoring the game, one move is played and then the game crashes with the following message:
ERROR: [VM] kGraph(RestoreBox): signature mismatch via method quickTurn::changeState (script 850, room 850, loc

Ticket imported from: #3057664. Ticket imported from: bugs/5322.

Attachments (1)

sq5.004 (33.3 KB ) - added by SF/negativeiq 9 years ago.
Gamesave that causes the crash (orignal name: sq5.004)

Download all attachments as: .zip

Change History (7)

by SF/negativeiq, 9 years ago

Attachment: sq5.004 added

Gamesave that causes the crash (orignal name: sq5.004)

comment:1 by SF/negativeiq, 9 years ago

Summary: Crashes on load BattleCruiser gameSQ5: Crashes on load BattleCruiser game

comment:2 by SF/negativeiq, 9 years ago

Please note attached gamesave file that reproduces the problem.

comment:3 by m-kiewitz, 9 years ago

Status: newclosed

comment:4 by m-kiewitz, 9 years ago

This artifact has been marked as a duplicate of artifact 3056811 with reason:
same bug, wasnt fixed before, typo

comment:5 by m-kiewitz, 9 years ago

Keywords: script added
Owner: set to m-kiewitz
Resolution: duplicate

comment:6 by m-kiewitz, 9 years ago

just checked the scripts, it seems the typo was done in here and not in the bugfix.
Seems to have been fixed properly already in r52477

Note: See TracTickets for help on using tickets.