Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5309 closed defect (fixed)

QFG1 VGA: Fetch spell crashes game

Reported by: SF/ghoost Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Quest for Glory 1

Description

ScummVM 1.2.0svn52392 (Aug 25 2010 20:59:27) on Linux x86
Quest for Glory I: So You Want to Be a Hero (VGA Remake, Demo/DOS/English)

If you try to get the spore of the spitng plants in the north with the fetch spell, the game crashes with this message:
Uninitialized read for temp 0 from method lassoFailed::changeState (script 16, room 16, localCall ffffffff)!

To reproduce the chrash, load the save game and cast the fetch spell.

Ticket imported from: #3053268. Ticket imported from: bugs/5309.

Attachments (1)

qfg1vga.002 (76.0 KB ) - added by SF/ghoost 9 years ago.
save file

Download all attachments as: .zip

Change History (12)

by SF/ghoost, 9 years ago

Attachment: qfg1vga.002 added

save file

comment:1 by bluegr, 9 years ago

I've added a fix in rev #52411, though I don't have that version of the game, thus I can't verify if it works. Please test it.

comment:2 by bluegr, 9 years ago

Owner: set to bluegr
Summary: QFG1 VGA: Fetch spell crash gameQFG1 VGA: Fetch spell crashes game

comment:3 by bluegr, 9 years ago

Status: newpending

comment:4 by bluegr, 9 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:5 by SF/jonww, 9 years ago

Still crashes in rev 52419.

comment:6 by SF/jonww, 9 years ago

FYI,
This issue is occurring in the non-demo version of the VGA remake as well.
win32/win7

comment:7 by bluegr, 9 years ago

jonww: Sorry, your comment is confusing. We are already talking about QFG1VGA here, and you reported that it occurs there too...?

comment:8 by SF/jonww, 9 years ago

I wanted to clarify because the details say it's for the demo version.

comment:9 by bluegr, 9 years ago

Fixed in rev #52440

comment:10 by bluegr, 9 years ago

Resolution: fixed
Status: pendingclosed

comment:11 by bluegr, 9 years ago

Sidenote: this was for the full version of the game, not the demo (as the initial comment said). There was no interactive demo of QFG1VGA, as far as I know

Note: See TracTickets for help on using tickets.