Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5306 closed defect (fixed)

SCI: Mute setting does not work

Reported by: OmerMor Owned by: m-kiewitz
Priority: blocker Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 3

Description

Game version: EGA/DOS/English/1.000
ScummVM version: 1.2.0svn52375
Platform: Windows7 32bit

All other audio devices are silent: mt32, pc speaker, fluidsynth, pcjr.
This is a regression from previous builds.

Ticket imported from: #3053104. Ticket imported from: bugs/5306.

Change History (12)

comment:1 by m-kiewitz, 9 years ago

for me mt32, pcJr and pc speaker is working w/o any issues.

comment:2 by OmerMor, 9 years ago

My fault: I didn't notice that the volume was set to mute in scummvm.
However - this raises another bug: adlib emulation is not affected by the volume settings.

comment:3 by OmerMor, 9 years ago

Summary: Only adlib emulation is workingadlib emulation is present when volume is set to mute

comment:4 by sev-, 9 years ago

Summary: adlib emulation is present when volume is set to muteSCI: Mute setting does not work

comment:5 by m-kiewitz, 9 years ago

fixed in r52484

volume changes are taken over to the game, *but* (most?) games set maximum volume right at the start by themselves. Anyway, mute will now work correctly.

comment:6 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed

comment:7 by bluegr, 9 years ago

Still occurs, according to bug #3060423, reopening

comment:8 by bluegr, 9 years ago

Resolution: fixed
Status: closednew

comment:9 by sev-, 9 years ago

Raising priority. This is a release-critical bug.

comment:10 by sev-, 9 years ago

Priority: normalblocker

comment:11 by sev-, 9 years ago

Closing with same reason as #3060423. Now it is bug/misfeature in Adlib emulator, not in the engine. Feel free to open Adlib-related bugreport.

comment:12 by sev-, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.