Opened 9 years ago

Closed 9 years ago

#5304 closed defect (fixed)

QFG1VGA and QFG3: Text box glitches

Reported by: SF/jonww Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 1

Description

SCUMMVM - ver 1.2.0svn52375

Quest for Glory I: So You Want to Be a Hero (VGA Remake/DOS/English)

Text box glich when casting calm / dazzle when not needed. (For practice)
Normally says \"Although that spell is not useful here, you at least had a chance to practice it.\"

Platform and Compiler Win 7 / Win32

Ticket imported from: #3053093. Ticket imported from: bugs/5304.

Attachments (2)

scummvm00000.bmp (105.5 KB) - added by SF/jonww 9 years ago.
Text Box Glich Pic
Screenshot.png (122.5 KB) - added by bluegr 9 years ago.
QFG3 screenshot, with the textbox glitch

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by SF/jonww

Attachment: scummvm00000.bmp added

Text Box Glich Pic

comment:1 Changed 9 years ago by m-kiewitz

the problem seems to be that the scripts remove the spells window after drawing the text window, resulting in parts of the text window to get removed.

comment:2 Changed 9 years ago by bluegr

Summary: QFG1VGA: Text box glichQFG1VGA and QFG3: Text box glitches

comment:3 Changed 9 years ago by bluegr

Bug #3039368 - "QFG3: Text Window Glitch" is a duplicate of this. From that bug: "If you start the game as a magician, once you're at Rakeesh's (after the intro), if you select a spell that can't be used (and you get a message window as a result), the message window is clipped (see attached screenshot)."

Updated the description of this accordingly

Changed 9 years ago by bluegr

Attachment: Screenshot.png added

QFG3 screenshot, with the textbox glitch

comment:4 Changed 9 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:5 Changed 9 years ago by bluegr

Fixed in rev #54662

Note: See TracTickets for help on using tickets.