Opened 17 years ago

Closed 16 years ago

Last modified 16 years ago

#528 closed defect (fixed)

DIG: No object descriptions shown

Reported by: SF/jbergstrom Owned by: aquadran
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

I wonder how I didn't already see this reported, since it
is so obvious, but...
In The Dig, when you point at an object (inventory item,
location, etc.) there shoud be a description text in the
middle of the screen, and now there isn't.

Ticket imported from: #632939. Ticket imported from: bugs/528.

Change History (10)

comment:1 Changed 17 years ago by SF/jbergstrom

Priority: normallow

comment:2 Changed 17 years ago by SF/arisme

I noticed that it was disabled in the source ... with the
comment

// FIXME: _talkdelay = 1 - display description, not correct
ego actor talking,
// 0 - no display, correct ego actor talking

(string.cpp, description)

I didn't notice oddities when setting it back to 1, perhaps it
was fixed recently or perhaps I haven't looked close enough :)

comment:3 Changed 17 years ago by fingolfin

Owner: set to SF/ender

comment:4 Changed 17 years ago by fingolfin

Ender, do you know more?

comment:5 Changed 17 years ago by fingolfin

Owner: changed from SF/ender to aquadran

comment:6 Changed 17 years ago by fingolfin

cvs annotate tells me that it was aquadran who made this
change on 15-Oct-02. Aquadran, would you please explain why
you commented out that code (i.e. to fix which issue) ?

comment:7 Changed 17 years ago by SF/ender

aquadran made a change, which broke descriptions completely
(so I commented out the trigger code for it myself).

The basic problem is that the text has issues with fading out (or
not fading out) based on talkDelay. This breaks horribly with
descriptions (and also the ending credits), because this feature
potentially allows more than one text string to be displayed at
once. Eg, a description tag AND speech from an actor talking.

The string code needs a fundemental rewrite, or at least minimum
support for dealing correctly with having multiple strings
displayed at once. It has many problems with this at the moment,
most stemming from talkDelay.. but I can imagine there are
probably issues because we only use one gdi.mask buffer.

comment:8 Changed 17 years ago by SF/khalek

bug 667846 has been marked a duplicate of this and closed

comment:9 Changed 16 years ago by fingolfin

This is fixed (though it shows the problems we have when scrolling - old text is not properly scrolled / erased, leaving garbage behind.

comment:10 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.