Opened 9 years ago

Closed 9 years ago

#5265 closed defect (duplicate)

LB2Floppy & LB2CD: Actor takes strange path

Reported by: SF/philohippus Owned by: waltervn
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

Laura Bow 2: The Dagger of Amon Ra (CD/DOS/English), version 1.1
Laura Bow 2: The Dagger of Amon Ra (DOS/English), version 1.000
ScummVM 1.2.0svn52199

Situation: Laura enters mastodon skeleton room from the right
Bug: Laura takes weird u turn before resting on correct entry spot. No console output.

Attached savegame. Saved at start of weird motion, all movement shown before regaining control of the mouse is pathfinder weirdness.

Ticket imported from: #3048213. Ticket imported from: bugs/5265.

Attachments (1)

laurabow2-1.002 (49.2 KB ) - added by SF/philohippus 9 years ago.
Savegame

Download all attachments as: .zip

Change History (7)

by SF/philohippus, 9 years ago

Attachment: laurabow2-1.002 added

Savegame

comment:1 by m-kiewitz, 9 years ago

Owner: set to waltervn

comment:2 by bluegr, 9 years ago

After the latest changes regarding scaling, the actor no longer takes a strange path. However, when entering the room to the right, Laura suddenly stops moving her feet, and eventually the game will crash after clicking around

comment:3 by SF/philohippus, 9 years ago

hmm I still have the actor taking the u-turn path but it just got weirder, the actor's feet don't move, she just hovers forth and back.

By the way, I didn't file a bug report for this because I thought you guys were surely aware of it, but just to check, you know that the SCI restore/save windows is gone right? The standard ScummVM UI window pops up now.

comment:4 by bluegr, 9 years ago

The weirdness should be fixed now, though yes, the issue still exists.

Regarding the save/load windows, this isn't a bug, we replaced the original save/load windows (which were dull and clumsy) with ScummVM's ones, which show thumbnails, time played etc. If you want to have the original save/load dialogs back you can enable them from the config file (scummvm.ini) by putting this line:
sci_originalsaveload=true
in the options

comment:5 by bluegr, 9 years ago

Resolution: duplicate
Status: newclosed

comment:6 by bluegr, 9 years ago

Duplicate of bug #3047418, closing

Note: See TracTickets for help on using tickets.