Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#526 closed defect (worksforme)

SAM: Game crashes (x not in room)

Reported by: SF/jbergstrom Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

In Sam and Max CD, the game crashes *very*
frequently due to either "Error(15:68:0x833): charset 6
not in room 1 at 450+258889!" or similar, or "Error
(9:48:0x164): script 2 not in room 1 at 450+91562!"
when you try to eg. pick up someting, select something
in inventory or exit a room.

Ticket imported from: #632555. Ticket imported from: bugs/526.

Attachments (1)

samnmax.s01 (56.0 KB) - added by SF/jbergstrom 17 years ago.
A Savegame

Download all attachments as: .zip

Change History (8)

comment:1 Changed 17 years ago by SF/ender

I just played straight from the beginning to the gator golf part of Sam and
Max, using the latest CVS, with no problems at all.

I'd be inclined to say this is a corrupt file, scratch on your cd, ecetra. I don't
suppose your running it from the same cd that you are playing music from?
If so, please see the README file for an important note.

Any further details? I cannot find anyone who can replicate this bug, it
seems to be something wrong with your copy.

comment:2 Changed 17 years ago by SF/ender

Owner: set to SF/ender

comment:3 Changed 17 years ago by SF/jbergstrom

I can't see how playing music could affect this, as music in
Sam and Max is midi.
And if you mean Bumpus singing (that's the only thing about
SNM in the readme), I haven't yet gotten that far.
And by all means, I don't think my copy is damaged. Actually,
it's one of my best kept CD's :)

Even with the latest CVS this problem persists, though a bit
fewer and so that it mostly is a room that is not in room 1.

I don't know if it has anything to do with this problem, but a
short while before SNM crashes, "WARNING:
addMessageToStack(): string escape sequence 1 unknown"
appears in output.

comment:4 Changed 17 years ago by SF/jbergstrom

Sorry, I mixed things up a little...
The addMessageToStack Warning came up only earlier,
when 'charset not in room' and 'script not in room' occurred.

Now, as only 'room not found' seems to occur, the warning is
different, as caused by my latest attempt to play:

WARNING: o6_miscOps: _saveSound=1!
WARNING: SE::start_sound failed: Couldn't find sound 1!
Error(25:80:0xC2): room 1 not found in room 15 at
4008053+0!

I also attached a save game, if that could be of some use. In
my experience, if you exit the trailer and exit the screen
between Wak-a-rat tent and the trailer, SNM often (but not
always) crashes. Another frequent place is at Gator Golf,
either when Mx is hit by Bumpus or when he land in the
Bigfoot booth.

comment:5 Changed 17 years ago by SF/jbergstrom

Sorry, I mixed things up a little...
The addMessageToStack Warning came up only earlier,
when 'charset not in room' and 'script not in room' occurred.

Now, as only 'room not found' seems to occur, the warning is
different, as caused by my latest attempt to play:

WARNING: o6_miscOps: _saveSound=1!
WARNING: SE::start_sound failed: Couldn't find sound 1!
Error(25:80:0xC2): room 1 not found in room 15 at
4008053+0!

I also attached a save game, if that could be of some use. In
my experience, if you exit the trailer and exit the screen
between Wak-a-rat tent and the trailer, SNM often (but not
always) crashes. Another frequent place is at Gator Golf,
either when Mx is hit by Bumpus or when he land in the
Bigfoot booth.

Changed 17 years ago by SF/jbergstrom

Attachment: samnmax.s01 added

A Savegame

comment:6 Changed 17 years ago by SF/ender

The warning means nothing.
And I -still- cannot reproduce this problem at all, even with your
save game. And I've spent over 8 hours testing it, without having
a -single- crash.

Sorry, it sounds like this is definatly something wrong with your
copy. Try copying your datafiles off the cd to your harddrive.

Closing bug report, unreproducable.

comment:7 Changed 17 years ago by SF/ender

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.