Opened 9 years ago

Closed 9 years ago

#5251 closed defect (fixed)

PQ3EGA: ScummVM crashes on launch

Reported by: SF/musiclyinspired Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 3

Description

svn52122

Can't even start the game. ScummVM crashes on launch. No time to read anything in the console.

Ticket imported from: #3046573. Ticket imported from: bugs/5251.

Change History (7)

comment:1 by SF/mthreepwood, 9 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by SF/mthreepwood, 9 years ago

We can't do anything without that info - see http://www.scummvm.org/faq/#5_6

comment:3 by SF/musiclyinspired, 9 years ago

* ScummVM version (PLEASE test the latest SVN/Daily build)

I stated the SVN version I'm using. It's at the very beginning of the summary. 1.2.0svn52122. Everything else I posted on the ScummVM forums in the SCI beta test thread like everyone else is doing.

* Bug details, including instructions on reproducing it

How do you reproduce it? Just try launching the game.

* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)

Again, I said all this on the ScummVM forums where it was asked for but I'll give it all here again:

English
Police Quest III: The Kindred - EGA/Floppy/DOS
Win32 XP SP3

* Attach a save game if possible

The game won't even launch.

* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

I've only tried it on the latest build revision (52122).

comment:4 by SF/musiclyinspired, 9 years ago

Here's the console output:

User picked target 'pq3-1' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10,
SCI11]
Starting 'Sierra SCI Game'
The game in 'G:\Games\Adventures\Sierra\PQCOL\PQ3EGA\' seems to be unknown.
Please, report the following data to the ScummVM team along with name
of the game you tried to add and its version/language/etc.:
"resource.002", "fc9452f962bd7a9bbf6e78e9e52a8e18", 692676
"resource.003", "31c226bf01b69c8182b8ca0e8760b0a7", 527848
"resource.000", "7659713720d61d9465a59091b7ee63ea", 402208
"resource.001", "0284ca44341fbc3cb7a047e49d230234", 703373
"resource.map", "1341f7c9643947414a8e238b88f68d82", 5901
"resource.004", "b96a86ab681769e4cbb439670d967ca6", 449682
"resource.005", "9e6c53a0e7eef53694d260fade8b1fc7", 724000

Though, it detects it as the EGA version of PQ3 so I don't know why it's discovering "unknown" resources here...

comment:5 by SF/musiclyinspired, 9 years ago

Actually, a lot of the SCI games I've tried give the message "This game seems to be unknown, please report the following data...etc etc" even though ScummVM properly detects what game and version it is...

comment:6 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:7 by bluegr, 9 years ago

This was a problem with a change introduced in the fallback detector, which has been fixed in rev #52163

Also added this version to our detection tables (rev #52166)

Note: See TracTickets for help on using tickets.