Opened 17 years ago

Closed 17 years ago

#525 closed defect (worksforme)

DIG: Crash during conversation

Reported by: SF/xplo Owned by: SF/ender
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

When Maggie talks with the white dragon-like alien. A
few specific topic make scummvm crash completely.
Also during this dialogue nearly all of the aliens speech
is cut half way thru. It seems as if the game isn't waiting
for it to finish properly and proceeding to the next line.

Attached is a german savegame made during the
conversation. To trigger the crashes talk about
the "ghost" or the "lightbridge" topics.

Ticket imported from: #630625. Ticket imported from: bugs/525.

Attachments (1)

dig.s28 (238.0 KB ) - added by SF/xplo 17 years ago.
german save just before the conversation.

Download all attachments as: .zip

Change History (11)

comment:1 by SF/xplo, 17 years ago

Priority: normalhigh
Summary: DIG:DIG: scummvm crashes during conversation

comment:2 by SF/ender, 17 years ago

Owner: set to SF/ender

comment:3 by SF/ender, 17 years ago

Can you please attach a saved game at or near this point, per
the bug reporting guidelines?

comment:4 by fingolfin, 17 years ago

Summary: DIG: scummvm crashes during conversationDIG: Crash during conversation

comment:5 by fingolfin, 17 years ago

What OS? What version of ScummVM?

comment:6 by SF/xplo, 17 years ago

Hmm, must have been stoned when I submitted these halfassed
bugreports sorry.

OS: WinXP (compiled with
VS.NET),
Version: was the CVS shortly before the report was
created.
With the CVS pulled a few minutes ago (see the comment
date) the error somewhat changed:
1. There is a few kernel(215)
messages appearing on the status console.
2. The said chat-topics
don't seem to crash anymore.
3. Long monologues from the alien are
still cut off.
4. Scummvm.exe now crashes when leaving the room the
conversation took place.

The attached german save was
"replayed" from a bit earlier, because Ender mentioned it could be
memory corruption. So I loaded a save from 30 mins earlier, and played
up to the trouble causing scene again.

by SF/xplo, 17 years ago

Attachment: dig.s28 added

german save just before the conversation.

comment:7 by SF/ender, 17 years ago

It still seems likely to me that the problem was caused by memory
corruption, expecially if the crash now occurs in a DIFFERENT
place.

The long monologues being cut off, is unrelated and caused by a
different issue.

The kernel() messages are completely unimportant, I think I've
left a debug printf() in by accident.

comment:8 by fingolfin, 17 years ago

Well the only way to find out would be to get somebody to
play to that point using current CVS from scratch, right?

comment:9 by SF/ender, 17 years ago

Resolution: worksforme
Status: newclosed

comment:10 by SF/ender, 17 years ago

Right.

I'm going to close this bug as worksforme - it's more likely this bug
was caused by one of the various memory corruption bugs
corrupting the save game... if someone can reproduce this,
please feel free to reopen a bug report.

Note: See TracTickets for help on using tickets.