Opened 9 years ago

Closed 3 years ago

#5248 closed defect (outdated)

SCI: SQ4EGA: Graphics Glitch in Arcade

Reported by: SF/musiclyinspired Owned by: sev-
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Space Quest 4

Description

When the time pod appears in the Arcade on the Galaxy Galleria the animation plays but when it stops it stops on an incorrect cel/loop and is only partially visible. The sequel police gets out of a partially visible time pod.

ScummVM 1.2.0svn52122

Savegame and screenshot attached.

Ticket imported from: #3046506. Ticket imported from: bugs/5248.

Attachments (2)

scummvm00020.jpg (160.2 KB) - added by SF/musiclyinspired 9 years ago.
sq4.003 (39.1 KB) - added by SF/musiclyinspired 9 years ago.
Walk to the back right of the Arcade for the time pod to appear

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by SF/musiclyinspired

Attachment: scummvm00020.jpg added

comment:1 Changed 9 years ago by bluegr

Resolution: worksforme

comment:2 Changed 9 years ago by bluegr

I can't reproduce this with the savegame you provided... can you try again?

Changed 9 years ago by SF/musiclyinspired

Attachment: sq4.003 added

Walk to the back right of the Arcade for the time pod to appear

comment:3 Changed 9 years ago by SF/musiclyinspired

I reuploaded a save game. Just walk to the right to make the tiem pod appear. Still does it for me.

comment:4 Changed 9 years ago by bluegr

Keywords: original added
Owner: set to bluegr
Resolution: worksforme
Status: newclosed

comment:5 Changed 9 years ago by bluegr

According to m_kiewitz, this occurs because the scripts at that point keep obtaining the elapsed time twice. This is a script timer bug, but it's mainly a (very) slight graphics glitch

Moving the the wiki, known bugs section

comment:6 Changed 4 years ago by m-kiewitz

Summary: SQ4EGA: Graphics Glitch in ArcadeSCI: SQ4EGA: Graphics Glitch in Arcade

comment:7 Changed 3 years ago by m-kiewitz

I can't reproduce this anymore.
Please verify using latest daily build. I guess another change fixed it already?!

comment:8 Changed 3 years ago by m-kiewitz

Status: closedpending

comment:9 Changed 3 years ago by sev-

Owner: changed from bluegr to sev-
Resolution: outdated
Status: pendingclosed
Note: See TracTickets for help on using tickets.