Opened 9 years ago

Closed 9 years ago

#5185 closed defect (wontfix)

KQ5: Crash after defeating Mordack

Reported by: SF/kurufinwe Owned by: bluegr
Priority: low Component: Engine: SCI
Keywords: original Cc:
Game: King's Quest 5

Description

After defeating Mordack and trying to use the wand on the castle (so right when Cassima is about to enter the lab), ScummVM crashes to the desktop.

Output just before crash:
WARNING: Error 6 occurred while reading sound.141 from resource file: Unknown compression method!
WARNING: resMan: Failed to read sound.141!
Bus error

Mac OS produces an error report, which I'm attaching.

(Random thought: In the CD version, this is exactly where the game would switch to a low quality audio track with digital music and voices mixed together for the big ending cutscene. Could ScummVM be confusing the versions and trying to look for that audio file, which of course does not exist in the floppy version? Of course, I've no idea what I'm talking about, so you should probably ignore this paragraph...)

Game version: DOS, Floppy, English, v. 0.000.062
ScummVM version: 1.2.0svn51829
Computer: MacBook 5,2, Mac OS X 10.6

Ticket imported from: #3041134. Ticket imported from: bugs/5185.

Attachments (2)

kq5.012 (54.1 KB ) - added by SF/kurufinwe 9 years ago.
Savegame; use wand, click rain spell
error.txt (27.2 KB ) - added by SF/kurufinwe 9 years ago.
Error report

Download all attachments as: .zip

Change History (11)

by SF/kurufinwe, 9 years ago

Attachment: kq5.012 added

Savegame; use wand, click rain spell

by SF/kurufinwe, 9 years ago

Attachment: error.txt added

Error report

comment:1 by bluegr, 9 years ago

Priority: normalhigh

comment:2 by bluegr, 9 years ago

Raising priority

comment:3 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:4 by bluegr, 9 years ago

Raising priority to 9, this is a release critical bug

comment:5 by bluegr, 9 years ago

Priority: highblocker

comment:6 by bluegr, 9 years ago

Keywords: original added
Priority: blockerlow

comment:7 by bluegr, 9 years ago

According to this thread made 6 years ago, this also happened in the original
interpreter:
http://www.agdiforums.com/forum/viewtopic.php?f=19&t=8825

It seems like the early disk version of KQ5 has a corrupted RESOURCE.001 file (where sound 141 is located), thus it's a problem with the game's resource files and not our bug. Lowering priority to 1, and adjusting resolution accordingly

comment:8 by bluegr, 9 years ago

There's nothing we can do about this issue, as it's caused by corrupt game resources. Added a page for this in the wiki

Closing

comment:9 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.