Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5182 closed defect (fixed)

KQ5 EGA: Corrupt graphics entering harpies' island

Reported by: SF/philohippus Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 5

Description

King's Quest V: Absence Makes the Heart Go Yonder (EGA/DOS/English), version 0.000.055
ScummVM 1.2.0svn51823

Situation: Approaching the island
Bug: Missing mountain graphics. Not present in DosBox.

Attached savegame and screenshot

Ticket imported from: #3041044. Ticket imported from: bugs/5182.

Attachments (2)

KQ5EGAScreenshot.png (55.3 KB ) - added by SF/philohippus 9 years ago.
Screenshot
kq5.002 (45.6 KB ) - added by SF/philohippus 9 years ago.
Savegame

Download all attachments as: .zip

Change History (10)

by SF/philohippus, 9 years ago

Attachment: KQ5EGAScreenshot.png added

Screenshot

by SF/philohippus, 9 years ago

Attachment: kq5.002 added

Savegame

comment:1 by SF/philohippus, 9 years ago

savegame: to enter problematic area, head south.

comment:2 by bluegr, 9 years ago

Happens when entering room 48

comment:3 by bluegr, 9 years ago

It seems that this bug is somehow caused by the way we handle priority in the picture drawing code (vector floodfill routines), in particular GfxPicture::vectorFloodFill() inside sci/graphics/picture.cpp

comment:4 by bluegr, 9 years ago

Forgot to mention that the whiteness comes from the priority screen

comment:5 by bluegr, 9 years ago

I tried to put some color clipping code in GfxPicture::vectorFloodFill(), clipping display colors to 0-15 (like in kGraphDrawLine(), kGraphFillBoxAny() and kNewWindow()). This fixes the flood fill for that scene, although the lines surrounding the flood fill are still white. Is this the proper solution for this bug, though? m_kiewitz?

comment:6 by bluegr, 9 years ago

Owner: set to m-kiewitz

comment:7 by bluegr, 9 years ago

Fixed in rev #54690

comment:8 by bluegr, 9 years ago

Owner: changed from m-kiewitz to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.