Opened 9 years ago

Closed 9 years ago

#5166 closed defect (fixed)

QFG3: Stuck animation

Reported by: SF/kuroshiro Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

Quest for Glory 3
ScummVM 1.2.0SVN 51782
Windows 7 x64

Again on the screen in the Simbani village with the bridge, if you fall off it by doing a flip near the end or something, you will go into the falling animation, but never come out of it. You can "Walk" around with the same animation stuck. See the attached save game to see the error. Leaving the screen fixes it.

Ticket imported from: #3040570. Ticket imported from: bugs/5166.

Attachments (1)

qfg3.004 (65.0 KB ) - added by SF/kuroshiro 9 years ago.
bug

Download all attachments as: .zip

Change History (7)

by SF/kuroshiro, 9 years ago

Attachment: qfg3.004 added

bug

comment:1 by SF/kuroshiro, 9 years ago

Note: it only seems to happen if you fall off by running out of stamina near the very end of the bridge.

comment:2 by m-kiewitz, 9 years ago

Please try this out in sierra sci and verify that it does not happen there.

comment:3 by SF/kuroshiro, 9 years ago

Can't reproduce in the original interpreter.

comment:4 by bluegr, 9 years ago

room 470

This could be related to bug #3039768 - "QFG3: Glitch When Making Thief Sign to Rope Maker"
https://sourceforge.net/tracker/index.php?func=detail&aid=3039768&group_id=37116&atid=418820#

It could be some sort of new signal for views which we are not handling properly

comment:5 by bluegr, 9 years ago

Fixed in rev #52207, it was a bug in the implementation of kSetJump (same as with bug #3039768)

comment:6 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.