Opened 9 years ago

Closed 9 years ago

#5136 closed defect (wontfix)

ECOQUEST1: Colour problems during scene changes

Reported by: SF/graxer Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: EcoQuest 1

Description

Game: EcoQuest II: The Search for Cetus
Game Version: Floppy/DOS/English
ScummVM Version: 1.2.0svn51728
Operating System: Ubuntu 10.04

During scene changes, the colours appear to invert as the new scene fades in. After the effect finishes the colours are fine. This can be seen during the intro with some of the dissolve effects which take place. (Although not all) It can also be seen during the game with completely different scene change effects. I have attached a picture.

Ticket imported from: #3039356. Ticket imported from: bugs/5136.

Attachments (2)

eco1.png (92.4 KB ) - added by SF/graxer 9 years ago.
A screenshot of the problem during the intro
eco12.png (119.9 KB ) - added by SF/graxer 9 years ago.
A second screenshot using a different scene change effect. In this only the scene I am leaving has odd colours.

Download all attachments as: .zip

Change History (4)

by SF/graxer, 9 years ago

Attachment: eco1.png added

A screenshot of the problem during the intro

by SF/graxer, 9 years ago

Attachment: eco12.png added

A second screenshot using a different scene change effect. In this only the scene I am leaving has odd colours.

comment:1 by bluegr, 9 years ago

Keywords: original added
Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:2 by bluegr, 9 years ago

Duplicate of bug #3038049

This is how the original SCI engine behaved, the colors of one scene mix with the colors of the next one. There's nothing we can do about it, the available palette colors just aren't enough. Read the other bug report for more info

Closing

Note: See TracTickets for help on using tickets.