Opened 9 years ago

Closed 9 years ago

#5127 closed defect (fixed)

Castle of Dr. Brain: Crash at robot jokes

Reported by: SF/thecrankyhermit Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Castle of Dr. Brain

Description

ScummVM version: 1.2.0svn51672
Game version: DOS/English
Platform: Win32

After completing the computer room and returning to the hall, clicking on the terminal at the end of the hall causes the VM to crash with this error:
[VM] kStrAt[62]: signature mismatch via method robotJokes::animateOnce (script 220, room 220, localCall 0xffffffff)!

Ticket imported from: #3039036. Ticket imported from: bugs/5127.

Attachments (1)

3039036saves.zip (76.6 KB ) - added by SF/thecrankyhermit 9 years ago.
Two savegames

Download all attachments as: .zip

Change History (9)

comment:1 by SF/thecrankyhermit, 9 years ago

Summary: Crash at robot jokesCastle of Dr. Brain: Crash at robot jokes

comment:2 by m-kiewitz, 9 years ago

can't reproduce this. What version of the game do you have? Please look into the VERSION file.

comment:3 by SF/thecrankyhermit, 9 years ago

My VERSION file contains:
1.000

comment:4 by SF/thecrankyhermit, 9 years ago

Just produced this a second time, playing on novice.

comment:5 by SF/thecrankyhermit, 9 years ago

I just realized there's another precondition for this crash. You must *not* have collected any jokes from the robot maze. If you have collected at least one joke, then it will not crash.

by SF/thecrankyhermit, 9 years ago

Attachment: 3039036saves.zip added

Two savegames

comment:6 by SF/thecrankyhermit, 9 years ago

Just attached two savegames.
BREAK has yet to attempt the robot maze. The game will crash when you click on the Robot Riddles console.
NOTBREAK has completed the robot maze. The Robot Riddles console works normally.

comment:7 by bluegr, 9 years ago

Keywords: script added
Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:8 by bluegr, 9 years ago

Fixed in rev #51817

Note: See TracTickets for help on using tickets.