Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5122 closed defect (fixed)

EQ1CD: Graphics glitch at Cetus head

Reported by: SF/escarlate Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: EcoQuest 1

Description

Found a small graphics glitch in the scene with Cetus head. After removing the harpoon, if Adam exits and enters the close-up, the wound is replaced by the earlier graphics showing the harpoon stuck in place. It is recognized as the wound, and the necessary action still can be performed to continue the game and complete it. I added a savegame of the scene below.

Ticket imported from: #3038904. Ticket imported from: bugs/5122.

Attachments (2)

ecoquest.014 (36.0 KB ) - added by SF/escarlate 9 years ago.
Eco1DOSaves.zip (51.7 KB ) - added by SF/escarlate 9 years ago.

Download all attachments as: .zip

Change History (13)

by SF/escarlate, 9 years ago

Attachment: ecoquest.014 added

comment:1 by SF/escarlate, 9 years ago

Game Version: CD/DOS/English/version 1.1
ScummVM Version: 1.2.0svn51672
Operating System: Win32 (XP SP2)

comment:2 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz

comment:3 by m-kiewitz, 9 years ago

please verify that this definitely does not happen when using original sci interpreter

comment:4 by SF/escarlate, 9 years ago

m_kiewitz: Do you have a DOS savegame near the head?

comment:5 by m-kiewitz, 9 years ago

of course not, that's why i was asking. I guess that issue is actually a game bug. In that case we won't fix it.

I was only able to check the other bug (crash when going left or right in that room) by warping to that location directly. Doing that means that i don't have the required items to heal the wound.

comment:6 by SF/escarlate, 9 years ago

Also happens when playing the floppy version with ScummVM. I tested the floppy version with the original interpreter in Dos Box, and it doesn't happen there. DOS/FLOPPY savegames attached below.

by SF/escarlate, 9 years ago

Attachment: Eco1DOSaves.zip added

comment:7 by SF/escarlate, 9 years ago

Oh, and it's the French floppy version.

comment:8 by SF/escarlate, 9 years ago

I guess this was quietly fixed then? As of svn51979, it's not happening anymore in either version. :)

comment:9 by m-kiewitz, 9 years ago

I guess this was fixed by fixing the kq5 trunk in the intro bug (r51969)

comment:10 by m-kiewitz, 9 years ago

Resolution: fixed
Status: newclosed

comment:11 by m-kiewitz, 9 years ago

This artifact has been marked as a duplicate of artifact 3037578 with reason:
same reason, sadly i have to revert the change for now

Note: See TracTickets for help on using tickets.