Opened 13 years ago

Closed 4 years ago

#5115 closed defect (fixed)

SCI: Missing music instruments

Reported by: SF/eddydrama Owned by: ZvikaZ
Priority: normal Component: Engine: SCI
Version: Keywords: midi
Cc: Game: Jones in the Fast Lane


Game: Jones In The Fast Lane Game Version: EGA/DOS/ENGLISH & Game Version: DOS/ENGLISH ScummVM Version: 1.2.0SVN51672 Operating System: WinXP (SP3)

Music does not play correctly on either of these games (both VGA and EGA versions have, as far as I can tell, exactly same problems same problems). Intro music is very close to being correct, but all the rest of the music are missing instruments (some more, some less).

When getting a job from unemployment office, normally there should be a fanfare type sound playing, it is currently missing and there is only a moment of silence instead.

Ticket imported from: #3038752. Ticket imported from: bugs/5115.

Change History (13)

comment:1 by fingolfin, 13 years ago

Summary: Jones in the Fast Lane: EGA & VGA music issuesJONES: EGA & VGA music issues

comment:2 by bluegr, 13 years ago

Which sound driver are you using? Adlib, MT-32, GM?

comment:3 by SF/eddydrama, 13 years ago

I have used the default setting as well as MT-32 and Adlib. All have the same problems, they all are missing some instruments.

comment:4 by SF/eddydrama, 13 years ago

I went back and tried with other drivers as well on svn52482 and they have problems as well.

Microsoft GS: Not only does it have the instruments missing, same as the others, but it also sounds quite bad. This is the first time I have tried with that setting. Pc Speaker Emulation: Not correct either. But I did remember that I love PC Speaker sounds, so something good from this. IBM PCjr Emulation: This one actually comes the closest to playing the tune on some places, such as Unemployment office and Monolith Burger. Does not seem to have the correct instruments and as far as sound quality goes, I have no idea as to how IBM PCjr should sound like originally.

But yeah, all seems to have the same problem. The CD version does not have the problem of missing instruments even though it has midi-music (well granted, it is a later version of the game so it probaply has some engine changes that ScummVM understands better)

I hope this helps.

comment:5 by bluegr, 13 years ago

Microsoft GS is General MIDI. The original game didn't support GM, only MT-32. We have an MT-32 <-> GM mapping, but it hasn't been tested for SCI 1 games, like Jones. I've added a warning for this

comment:6 by bluegr, 13 years ago

Updated description and merged duplicate bug #3034465 with this one. From that bug, in EcoQuest 2 the music at the Sierra logo screen is missing instruments with the Adlib driver.

Also, from the same bug: "I was using Adlib emulator. It appears that Microsoft GS Wavetable Synth sounds how I was expecting it to sound. With the Microsoft GS Wavetable Synth the music doesn't play properly at the very beginning of the game when the man is playing music from his briefcase (You just get the background beat, but not the main tune)"

comment:7 by bluegr, 13 years ago

Summary: JONES: EGA & VGA music issuesSCI: Missing music instruments

comment:8 by bluegr, 11 years ago

From duplicate bug #3602982:

I'm using the MT-32 Emulator from MUNT (latest version 1.0) that installs as a MIDI device in Windows to play music (I also note that the same thing happens when using scummvm's built in MT-32 emulator).

In scummvm, I've configured Scummvm to use the MT-32 Emulator (Windows) MIDI device, and I've also checked the options "Override global MT-32 settings" and "True Roland MT-32" so that scummvm sends MT-32 midi music to the emulator. I watched the introduction of the game and while the music *is* MT32 music, I noticed that in some sections it doesn't sound completely right, as if there are some instruments missing.

To compare, I ran the game in Dosbox and also configured Dosbox to use the same MIDI device (MT-32 Emulator in Windows). In dosbox, the music sounds right throughout the introduction.

So, it appears to me that the engine in scummvm is not sending all MT-32 midi commands to the midi device.

I tested this in ScummVM 1.6.0git2489-g45f95cb (Jan 15 2013 09:44:26) win32 Conquest of Longbow (English version)

comment:9 by wjp, 9 years ago

Parts of this are fixed by the recent sound code changes, such as the missing fanfare after getting a job.

comment:10 by csnover, 6 years ago

Keywords: midi added
Owner: set to csnover

comment:11 by digitall, 5 years ago

Owner: csnover removed

comment:12 by ZvikaZ, 4 years ago

Can someone who plays Jones give reference to an exact point of sound mismatch?
And even supply a save game?

comment:13 by ZvikaZ, 4 years ago

Owner: set to ZvikaZ
Resolution: fixed
Status: newclosed

Closing, as there's no response, I don't hear the problem, and it's been probably solved by , or any other audio change in the last 5 years.

Note: See TracTickets for help on using tickets.