Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5100 closed defect (duplicate)

QG3: Restoring from opening screen breaks game

Reported by: SF/kurufinwe Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

When restoring a save from the game's opening screen, the game is broken. For instance, when changing screens, the palette is not updated and bits from the former screen remain on the new one. In some circumstances, pathfinding also seems to be broken (though I can't reproduce it reliably).
In this broken state, restoring another save does not solve the problem.

However, if a save is loaded from the ScummVM menu, or a new game is started and a save is loaded after the introduction is over, the game works fine. Saves can then be restored from within the game without further problems.

So the problem is only triggered when restoring from the game's opening screen.

A sample savegame is attached.

Game version: DOS, English, v. 1.1
ScummVM version: 1.2.0svn51601
Computer: MacBook 5,2, Mac OS X 10.6

Ticket imported from: #3038227. Ticket imported from: bugs/5100.

Attachments (1)

qfg3.001 (41.6 KB ) - added by SF/kurufinwe 9 years ago.

Download all attachments as: .zip

Change History (6)

by SF/kurufinwe, 9 years ago

Attachment: qfg3.001 added

comment:1 by m-kiewitz, 9 years ago

Can't reproduce this at all.
Did you use the actual game restore menu or the ScummVM menu?
If you used the latter, please don't do it. Use the regular game restore menu.

comment:2 by SF/kurufinwe, 9 years ago

I'm sorry I wasn't clear. The problem occurs if you use the in-game menu on the opening screen (i.e. start the game, click Restore game). When you load the save, everything looks fine; buy as soon as you move to another screen, all hell breaks loose.

When loading from the ScummVM menu, everything works fine.

(I'm using v. 1.1 of the game, from the QfG Anthology, without the NRS patches -- in case that matters.)

comment:3 by m-kiewitz, 9 years ago

This artifact has been marked as a duplicate of artifact 3035626 with reason:
same reason

comment:4 by m-kiewitz, 9 years ago

Status: newclosed

comment:5 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: duplicate
Note: See TracTickets for help on using tickets.