Opened 9 years ago

Closed 9 years ago

#5096 closed defect (fixed)

QFG2: Crash during import dialog after time (import works)

Reported by: SF/toest Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Quest for Glory 2

Description

Game crashes when trying to load character from completed Quest for Glory 1.
Quest of Glory 1 was completed with ScummVM (same Version)

ERROR: [VM] kStrCpy[47]: signature mismatch via method getFileName::doit (script 806, room 805, localCall 0x3b4)

Game: Quest for Glory II: Trial by Fire
Game Version: DOS/English
ScummVM Version: 1.2.0svn51577
Operating System: Vista (32 bit)

Ticket imported from: #3037996. Ticket imported from: bugs/5096.

Change History (11)

comment:1 by m-kiewitz, 9 years ago

can't reproduce this. Importing in my version works like it should.

When does this happen exactly? After selecting the filename? Before the filenames are shown?

comment:2 by SF/toest, 9 years ago

This happend after viewing the introduction, choosing to import character,
Theb i think I tried to change directory, but realized I didn't have to so I canceled;
after marking the file, and hitting import.

Can't reproduce it now, instead it crashes when i try to scroll the file box (with mouse)

ERROR: [VM] kStrAt[62]: signature mismatch via method savedHeros::advance (script 255, room 805, localCall 0xff

comment:3 by m-kiewitz, 9 years ago

I guess its one of the filenames that you got in there. Could you please make a screenshot of your import menu and attach it here?

comment:4 by SF/toest, 9 years ago

There is just one file: glory1.sav

Will post a screenshot as soon as i come home.

comment:5 by m-kiewitz, 9 years ago

hmm scrolling works for me and i have 3 character files in there.
If you are able to reproduce it, please post the whole "parameter xx:" lines from debug console as well.

comment:6 by SF/toest, 9 years ago

Ok, this is strange, and I can't reproduce it every time.

first of all, importing works. selecting file and then clicking import works fine.

But: Sometimes when I scroll the window (there is just one save game: glory1.sav) it crashes on me.

Sometimes with the messages above and sometimes with:

Error: [VM] Attempt to add -13 to invalid pointer 002f:000!

This tends to happen if I click with the right mouse button and then the left mouse button on the scrollbuttons. But not everytime, so...

How can I provide more/better information on this?

comment:7 by m-kiewitz, 9 years ago

Summary: QFG2 Crash when attempting to load character from QFG1QFG2 Crash during import dialog after time (import works)

comment:8 by fingolfin, 9 years ago

Component: Engine: SCI
Game: Quest for Glory 2
Summary: QFG2 Crash during import dialog after time (import works)QFG2: Crash during import dialog after time (import works)

comment:9 by fingolfin, 9 years ago

What is the status of this item?

comment:10 by bluegr, 9 years ago

Keywords: script added
Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:11 by bluegr, 9 years ago

Fixed in rev 54407

Note: See TracTickets for help on using tickets.