Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5095 closed defect (fixed)

PQ3 : Graphical Glitch with White Mercedes on Freeway

Reported by: digitall Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 3

Description

In Police Quest 3, when pulling over the White Mercedes, graphical glitches seem to occur in both the Driving Interface view if you
click on the Mercedes and when Sonny walks in front of the patrol car to give Orpheus the ticket.

Will attach screenshots.

ScummVM 1.2.0svn51580 (Aug 1 2010 17:57:45)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ RGB zLib FluidSynth
on Linux 2.6.34 x86_32

Ticket imported from: #3037945. Ticket imported from: bugs/5095.

Attachments (5)

pq3.016 (40.5 KB) - added by digitall 9 years ago.
Savegame for Replication
scummvm00002.png (37.4 KB) - added by digitall 9 years ago.
Glitch when clicking on Mercedes in Driving Interface
scummvm00000.png (58.3 KB) - added by digitall 9 years ago.
Glitch in Room 29 when Sonny walks in front of Squad Car
scummvm00003.png (57.9 KB) - added by digitall 9 years ago.
Alternate Manifestation of Glitch in Room 29 when Sonny walks in front of Squad Car
PQ3SG.010 (23.7 KB) - added by digitall 9 years ago.
Original interpreter savegame for comparison

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by digitall

Attachment: pq3.016 added

Savegame for Replication

comment:1 Changed 9 years ago by digitall

Game version : Police Quest III: The Kindred (DOS/English)
Room : 29

Will see if this happened in the original interpreter.

Changed 9 years ago by digitall

Attachment: scummvm00002.png added

Glitch when clicking on Mercedes in Driving Interface

Changed 9 years ago by digitall

Attachment: scummvm00000.png added

Glitch in Room 29 when Sonny walks in front of Squad Car

Changed 9 years ago by digitall

Attachment: scummvm00003.png added

Alternate Manifestation of Glitch in Room 29 when Sonny walks in front of Squad Car

comment:2 Changed 9 years ago by m-kiewitz

I had none of those, although i played a multilingual pq3 version.

Please tell us what version that game is and if it's multilingual or not.

comment:3 Changed 9 years ago by digitall

This is the version of Police Quest 3 included in the Sierra Police Quest Collection CD-ROM.
The version file lists this as 1.00 and I can't find a version string in the interpreter, SCIDHUV.EXE.

I don't think this is the multi-lingual version.

comment:4 Changed 9 years ago by digitall

I have tried this with the original interpreter under DosBox and can't replicate the issue.
Am attaching savegame for original for comparison.

Changed 9 years ago by digitall

Attachment: PQ3SG.010 added

Original interpreter savegame for comparison

comment:5 Changed 9 years ago by m-kiewitz

can now reproduce this, because i got the pq collection now. Sierra SCI even works fine when using max cycles

comment:6 Changed 9 years ago by bluegr

Fixed in r54975

comment:7 Changed 9 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.