Opened 9 years ago

Closed 9 years ago

#5051 closed defect (fixed)

LSL2: Long cutscene

Reported by: SF/escarlate Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 2

Description

The ship cutscene takes several minutes to play out and move to the boat map. I attached two savegames, one prior to getting into the cruiser, and another with the cutscene playing. The normal behaviour can be seen here: http://www.youtube.com/watch?v=Yv9hQsC1ybQ&feature=related

Console output:

WARNING: Read for a parameter goes out-of-bounds, onto the stack and gets uninitialized temp!
WARNING: setAttribute() called with unsupported attributeId 34!
WARNING: Bad command or running status 00!

Game Version: DOS/English/v.1.000.011
ScummVM Version: 1.2.0svn51496
Operating System: Win32 (XP SP2)

Ticket imported from: #3037012. Ticket imported from: bugs/5051.

Attachments (2)

lsl2.010 (31.4 KB) - added by SF/escarlate 9 years ago.
lsl2.004 (35.3 KB) - added by SF/escarlate 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by SF/escarlate

Attachment: lsl2.010 added

Changed 9 years ago by SF/escarlate

Attachment: lsl2.004 added

comment:1 Changed 9 years ago by m-kiewitz

is caused by the music not playing, scripts aren't cued because of this so they wait quite a long time

comment:2 Changed 9 years ago by m-kiewitz

fixed in r52513

comment:3 Changed 9 years ago by m-kiewitz

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.