Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5047 closed defect (fixed)

KQ5 EGA (0.000.055 & 0.000.062) Crash on Startup

Reported by: OmerMor Owned by: SF/mthreepwood
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 5

Description

I get the following for both versions:

User picked target 'kq5-1' (gameid 'sci')... Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10, SCI11, SCI32] Starting 'Sierra SCI Game' WARNING: Error 1 occurred while reading vocab.0 from resource file: I/O error! WARNING: resMan: Failed to read vocab.0! WARNING: Could not find a main vocabulary! WARNING: Error 1 occurred while reading script.998 from resource file: I/O error ! WARNING: resMan: Failed to read script.998!

Ticket imported from: #3036993. Ticket imported from: bugs/5047.

Change History (7)

comment:1 by bluegr, 10 years ago

That looks like corrupted resource files. Does the game work with the original interpreter?

comment:2 by OmerMor, 10 years ago

It works perfectly in DosBox using the original interpreter. Maybe it fails to detect the sci version correctly? I can send you the resource files if you want to examine it. Just give me your email address.

comment:3 by SF/mthreepwood, 10 years ago

Could you try this again after r51619?

comment:4 by m-kiewitz, 10 years ago

Owner: set to SF/mthreepwood

comment:5 by OmerMor, 10 years ago

Thanks - fixed!

comment:6 by OmerMor, 10 years ago

Resolution: fixed
Status: newclosed

comment:7 by OmerMor, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

Note: See TracTickets for help on using tickets.