Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#503 closed defect (worksforme)

MI1VGA: Crashes when entering the room

Reported by: SF/aldimann Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM 0.2.7 (scummvm actually says it's 0.2.2, but it's
0.2.7) on win32
monkeyvga / german

scummvm
crashes everytime i try to go inside of that church-like-
building...

---
State Loaded from
'monkeyvga.s09'
Loading room 78
Fatal signal:
Segmentation Fault (SDL Parachute Deployed)
---

Ticket imported from: #627678. Ticket imported from: bugs/503.

Attachments (1)

monkeyvga.s09 (31.1 KB ) - added by SF/aldimann 17 years ago.
SaveGame

Download all attachments as: .zip

Change History (12)

by SF/aldimann, 17 years ago

Attachment: monkeyvga.s09 added

SaveGame

comment:1 by fingolfin, 17 years ago

Works for me with latest CVS, monkeyvga / german, room 78 (BTw the
church-like-building actually is a church :-)

Maybe it's a problem with your music driver? Which music driver do you
use (null, adlib, ... as chosen with the -e option).

comment:2 by Kirben, 17 years ago

Summary: Crashes when entering the roomMI1VGA: Crashes when entering the room

comment:3 by SF/aldimann, 17 years ago

I used the default sound driver (adlib, i guess), but it also crashes when
using the null-output.

And it's no graphic-error, because it
crashes when using the normal-mode instead of the
supereagle.

btw: my english's very bad, you see ;)

Oh,
here's my
scummvm.ini:

[scummvm]
gfx_mode=supereagle
fullscreen=true

[monkeyvga]
path=C:\monkey

comment:4 by fingolfin, 17 years ago

Is this with latest CVS?

Also, what exactly do you do... do you do this:
* start a new game in monkeyvga
* go straight to the church
* enter the church
* walk around in church

That's what I do and it works flawlessly over here. Or are you using a
savegame? If you are using a savegame, try to test with a new game
instead.

comment:5 by SF/aldimann, 17 years ago

Well, it just downloaded the latest cvs and started a new game, but it still
doesnt work...

comment:6 by SF/aldimann, 17 years ago

Where's the Edit-Button? ;)

What I wanted to say:
"Well, It
just downloaded.."

comment:7 by fingolfin, 17 years ago

Owner: set to SF/ender

comment:8 by fingolfin, 17 years ago

I guess it still happens with latest CVS?

Endy, do you have an idea?

comment:9 by fingolfin, 17 years ago

I just can't reproduce this with my german MonkeyVGA. If
nobody else can reproduce this, I'd recommend closing this
as WORKSFORME.

comment:10 by SF/ender, 17 years ago

Closing as WORKSFORME.

comment:11 by SF/ender, 17 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.